Skip to content

Remove old sqlite adapter #6011

Merged
merged 7 commits into from Apr 27, 2012

3 participants

@aderyabin

SQLite adapter is NOT compatible with SQLite 3. Why Rails should continue support this antiques? I don't know. I think that only mad can say 'Lets work with rails3 (4?) but with SQLite < 3.

I suggest to stop drag this heritage and continue support only sqlite3.

cc @fxn @tenderlove

@jonleighton jonleighton merged commit 7d1a42a into rails:master Apr 27, 2012
@jonleighton
Ruby on Rails member

👍 for the slightly Shakespearean tone in your pull request ;)

@pixeltrix pixeltrix added a commit that referenced this pull request Apr 22, 2015
@pixeltrix pixeltrix Remove sqlite support from `rails dbconsole`
Support for versions of SQLite less than 3 was removed in #6011 as part
of the Rails 4.0 release. Therefore there is no need to have support for
it in the `rails dbconsole` command anymore.
688c0ec
@radar radar added a commit to radar/rails that referenced this pull request Jul 22, 2015
@pixeltrix pixeltrix Remove sqlite support from `rails dbconsole`
Support for versions of SQLite less than 3 was removed in #6011 as part
of the Rails 4.0 release. Therefore there is no need to have support for
it in the `rails dbconsole` command anymore.
d39359b
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Something went wrong with that request. Please try again.