Update supported ruby versions error message in ruby_version_check.rb #7836

Merged
merged 1 commit into from Oct 3, 2012

Projects

None yet

2 participants

@lihanli

I'm assuming Rails supports 1.9.3 because the official test box is using it.

@rafaelfranca rafaelfranca commented on an outdated diff Oct 3, 2012
railties/lib/rails/ruby_version_check.rb
@@ -14,7 +14,7 @@
$stderr.puts <<-end_message
Rails 3 doesn't officially support Ruby 1.9.1 since recent stable
- releases have segfaulted the test suite. Please upgrade to Ruby 1.9.2.
+ releases have segfaulted the test suite. Please upgrade to Ruby 1.9.3.
@rafaelfranca
rafaelfranca Oct 3, 2012

I think is better to use:

Please upgrade to Ruby 1.9.2 or later.
@rafaelfranca rafaelfranca commented on an outdated diff Oct 3, 2012
railties/lib/rails/ruby_version_check.rb
@@ -2,7 +2,7 @@
desc = defined?(RUBY_DESCRIPTION) ? RUBY_DESCRIPTION : "ruby #{RUBY_VERSION} (#{RUBY_RELEASE_DATE})"
abort <<-end_message
- Rails 3 requires Ruby 1.8.7 or 1.9.2.
+ Rails 3 requires Ruby 1.8.7 or >=1.9.2.
@rafaelfranca
rafaelfranca Oct 3, 2012

please put a space after the >=

@lihanli

OK, I made the changes.

@rafaelfranca rafaelfranca merged commit 95369a5 into rails:3-2-stable Oct 3, 2012
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment