Skip to content


Lock sprockets to 2.2.x #8161

merged 1 commit into from

5 participants

Ruby on Rails member

Rails is failing with sprockets >= 2.3, see #8099 for reference and discussion.

I think we should address the issue anyway and relax the dependency again later but right now this is being a blocker for 3.2.9 release since last week.

We isolated the problem to sass-rails but we don't have much idea right now about how to fix it

@rafaelfranca rafaelfranca merged commit 68e001f into rails:3-2-stable
Ruby on Rails member

But this forces 3.2.8 apps on newer sprockets to downgrade when they upgrade to 3.2.9.

Ruby on Rails member

3.2.8 depends on sprockets ~> 2.1.3 so they don't have to downgrade

Ruby on Rails member

confirm, 3.2.8 is depending in 2.1.3

Ruby on Rails member

Great! I thought 83e0c95 was applied before release.


Why is Sprockets still locked now that #8099 is fixed?


Ah, nevermind. I see that the Sprockets-dependency has been pulled into sprockets-rails in Rails 4.


What about Rails 3.2.x apps ? As #8099 is solved, shouldn't they also use the latest sprockets version 2.9.x ?

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Commits on Nov 9, 2012
  1. @guilleiguaran

    Lock sprockets to 2.2.x

    guilleiguaran committed
Showing with 1 addition and 1 deletion.
  1. +1 −1 actionpack/actionpack.gemspec
2 actionpack/actionpack.gemspec
@@ -23,7 +23,7 @@ do |s|
s.add_dependency('rack', '~> 1.4.0')
s.add_dependency('rack-test', '~> 0.6.1')
s.add_dependency('journey', '~> 1.0.4')
- s.add_dependency('sprockets', '~> 2.2')
+ s.add_dependency('sprockets', '~> 2.2.1')
s.add_dependency('erubis', '~> 2.7.0')
s.add_development_dependency('tzinfo', '~> 0.3.29')
Something went wrong with that request. Please try again.