Lock sprockets to 2.2.x #8161

Merged
merged 1 commit into from Nov 9, 2012

Conversation

Projects
None yet
5 participants
@guilleiguaran
Member

guilleiguaran commented Nov 9, 2012

Rails is failing with sprockets >= 2.3, see #8099 for reference and discussion.

I think we should address the issue anyway and relax the dependency again later but right now this is being a blocker for 3.2.9 release since last week.

We isolated the problem to sass-rails but we don't have much idea right now about how to fix it

rafaelfranca added a commit that referenced this pull request Nov 9, 2012

Merge pull request #8161 from guilleiguaran/downgrade-sprockets
Lock sprockets to 2.2.x

REASON: We had some pending fixes in sprockets and sass-rails to make possible to use sprockets version > 2.2. We will do a more conservative sprockets upgrade for this release.

In a next release we can relax the dependency again.

See #8099 for more information.

@rafaelfranca rafaelfranca merged commit 68e001f into rails:3-2-stable Nov 9, 2012

rafaelfranca added a commit that referenced this pull request Nov 9, 2012

Merge pull request #8161 from guilleiguaran/downgrade-sprockets
Lock sprockets to 2.2.x

REASON: We had some pending fixes in sprockets and sass-rails to make possible to use sprockets version > 2.2. We will do a more conservative sprockets upgrade for this release.

In a next release we can relax the dependency again.

See #8099 for more information.
@jeremy

This comment has been minimized.

Show comment
Hide comment
@jeremy

jeremy Nov 9, 2012

Member

But this forces 3.2.8 apps on newer sprockets to downgrade when they upgrade to 3.2.9.

Member

jeremy commented Nov 9, 2012

But this forces 3.2.8 apps on newer sprockets to downgrade when they upgrade to 3.2.9.

@rafaelfranca

This comment has been minimized.

Show comment
Hide comment
@rafaelfranca

rafaelfranca Nov 9, 2012

Member

3.2.8 depends on sprockets ~> 2.1.3 so they don't have to downgrade

Member

rafaelfranca commented Nov 9, 2012

3.2.8 depends on sprockets ~> 2.1.3 so they don't have to downgrade

@guilleiguaran

This comment has been minimized.

Show comment
Hide comment
@guilleiguaran

guilleiguaran Nov 9, 2012

Member

confirm, 3.2.8 is depending in 2.1.3

Member

guilleiguaran commented Nov 9, 2012

confirm, 3.2.8 is depending in 2.1.3

@jeremy

This comment has been minimized.

Show comment
Hide comment
@jeremy

jeremy Nov 9, 2012

Member

Great! I thought 83e0c95 was applied before release.

Member

jeremy commented Nov 9, 2012

Great! I thought 83e0c95 was applied before release.

@judofyr

This comment has been minimized.

Show comment
Hide comment
@judofyr

judofyr May 13, 2013

Why is Sprockets still locked now that #8099 is fixed?

judofyr commented May 13, 2013

Why is Sprockets still locked now that #8099 is fixed?

@judofyr

This comment has been minimized.

Show comment
Hide comment
@judofyr

judofyr May 13, 2013

Ah, nevermind. I see that the Sprockets-dependency has been pulled into sprockets-rails in Rails 4.

judofyr commented May 13, 2013

Ah, nevermind. I see that the Sprockets-dependency has been pulled into sprockets-rails in Rails 4.

@KDGundermann

This comment has been minimized.

Show comment
Hide comment
@KDGundermann

KDGundermann May 21, 2013

What about Rails 3.2.x apps ? As #8099 is solved, shouldn't they also use the latest sprockets version 2.9.x ?

What about Rails 3.2.x apps ? As #8099 is solved, shouldn't they also use the latest sprockets version 2.9.x ?

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment