Write config.threasafe! deprecated waning in config/environments/production.rb #8232

Closed
wants to merge 1 commit into from

4 participants

@yasuoza

Since Rails 4.0 config.threadsafe! is enabled by default.
I think we have to strongly warn users about it by not only showing deprecated warnings when
user use this option, but also writing deprecated warnings in config file.

@yasuoza yasuoza config.threasafe! deprecated waning in config/environments/production.rb
Since Rails 4.0 config.threadsafe! is enabled by default.
We have to strongly warn to users by not only showing deprecated warnings when
user use this option, but also writing deprecated warnings in config file.
db71ab5
@rafaelfranca
Ruby on Rails member

I would just remove it from the configuration file. I don't know why it is still there.

@josevalim
Ruby on Rails member

Yup, it should simply be removed.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment