Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

Already on GitHub? Sign in to your account

PR #5219 backported to 3-2 #9368

Merged
merged 1 commit into from Sep 10, 2013

Conversation

Projects
None yet
8 participants

beedub commented Feb 22, 2013

This is the 3-2 patch that mimics #5219.

Member

steveklabnik commented Feb 25, 2013

saberma commented Apr 3, 2013

+1

I think that for 3-2 it's going to need a changelog entry. Thanks.

jwlibby commented Apr 9, 2013

+1 - is there any eta on when this can be merged in and available in a release?

+1 : I just hit this in our codebase, and it is super annoying, as it's pretty hard to test these routes without this.

beedub commented Jun 3, 2013

Sorry it took so long, but I've finally updated the changelog.

@steveklabnik @carlosantoniodasilva can we get this merged? it would be much appreciated!

Member

steveklabnik commented Aug 30, 2013

It doesn't merge cleanly any more.

beedub commented Aug 30, 2013

It doesn't merge cleanly any more.

@steveklabnik resolved the merge conflicts and pushed as 324f562

Member

robin850 commented Aug 31, 2013

The build is passing, @steveklabnik could you merge it please ?

Member

steveklabnik commented Sep 4, 2013

Sorry @beedub , I should have mentioned before, I need these all squashed into one commit.

Member

steveklabnik commented Sep 4, 2013

(after that it's good to go, I swear.)

Member

robin850 commented Sep 4, 2013

Oops sorry Steve, didn't noticed that! 😊

beedub commented Sep 6, 2013

@steveklabnik

$ ruby -Itest:lib:/Users/bhahn/cf/apps/rails/railties/../activesupport/lib:/Users/bhahn/cf/apps/rails/railties/../actionpack/lib test/application/routing_test.rb

I've run that several times on 1.8.7-p374, and it fails in different ways almost every time. Is there something non-deterministic about running a single test? Is this note related?

Member

steveklabnik commented Sep 7, 2013

I have no idea, I haven't even had 1.8 installed on the last two machines I've owned. :/

beedub commented Sep 7, 2013

And now travis says everything's okay. I'm not really sure if this is the forum for this, but something seems broken somewhere -- travis, the actual tests, testing framework, something else?

beedub commented Sep 10, 2013

@steveklabnik any thoughts? would like not to have this linger again for many months

@steveklabnik steveklabnik added a commit that referenced this pull request Sep 10, 2013

@steveklabnik steveklabnik Merge pull request #9368 from CrowdFlower/3-2-stable
PR #5219 backported to 3-2
cff8d1d

@steveklabnik steveklabnik merged commit cff8d1d into rails:3-2-stable Sep 10, 2013

1 check passed

default The Travis CI build passed
Details
Member

steveklabnik commented Sep 10, 2013

We'll chalk it up to Travis errors. Thanks.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment