Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with
or
.
Download ZIP

Loading…

sass-rails 3.1.6 doesn't work with sass 3.1.18 #106

Closed
flipkick opened this Issue · 5 comments

5 participants

@flipkick

Using rails 3.1.2, sass 3.1.18 and sass-rails 3.1.6 fails while precompiling the asset with an empty screen.css:

** Execute assets:precompile:primary
rake aborted!
stack level too deep
(in /Users/xxx/work/xxx/app/assets/stylesheets/screen.css.sass)

required in application.rb via:
config.assets.precompile += ["screen.css"]

downgrading to sass-rails 3.1.5 fixes this problem for now.

@jfirebaugh

See also #78 and #100.

@glebm

Can't downgrade on Rails 3.2:
Any ideas?

Bundler could not find compatible versions for gem "railties":

In Gemfile:

sass-rails (= 3.1.5) ruby depends on
  railties (~> 3.1.0) ruby

coffee-rails (>= 0) ruby depends on
  railties (3.2.8)
@costa

hours burnt, innocent blamed sass/sass#575
3.1.6 doesn't work with sass 3.1.21 or 3.2.3 here (rails 3.1.8 if you want to know)
back to 3.1.5
uneasy

@frodsan

@flipkick Is this still an issue? Can you test it with 3.1.7?

@frodsan

Closing here, because there haven't get any update since months. Please try it with a newer version.

@frodsan frodsan closed this
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Something went wrong with that request. Please try again.