Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Fix Ruby 2.7 deprecation in helper.rb #454

Merged
merged 1 commit into from Dec 27, 2019

Conversation

connorshea
Copy link
Contributor

@connorshea connorshea commented Dec 27, 2019

This is a sibling PR to rails/sprockets#660. This needs to be changed to fix sprockets-rails causing a deprecation warning after the sprockets deprecation warning is fixed.

I've tested this on my Rails app and my test suite passes just fine with this change even if the sprockets change isn't present.

Oddly, this may actually be the only change that's necessary. I don't see any deprecation warning anymore with just this PR, regardless of whether the sprockets change is made or not.

@rafaelfranca rafaelfranca merged commit b0b380e into rails:master Dec 27, 2019
1 check failed
@connorshea connorshea deleted the fix-ruby-27-deprecations branch Dec 29, 2019
gabebw added a commit to hotline-webring/hotline-webring that referenced this issue Jul 2, 2020
We need this PR to prevent warnings from Ruby 2.7:
rails/sprockets-rails#454

However, the last sprockets-rails release was in 2017, so we grab it
from GitHub. It's pinned to the earliest ref that includes that PR so
that we don't always grab the latest master (which is a shifting target
and could introduce instability).
gabebw added a commit to hotline-webring/hotline-webring that referenced this issue Jul 2, 2020
We need this PR to prevent warnings from Ruby 2.7:
rails/sprockets-rails#454

However, the last sprockets-rails release was in 2017, so we grab it
from GitHub. It's pinned to the earliest ref that includes that PR so
that we don't always grab the latest master (which is a shifting target
and could introduce instability).
gabebw added a commit to hotline-webring/hotline-webring that referenced this issue Jul 2, 2020
We need this PR to prevent warnings from Ruby 2.7:
rails/sprockets-rails#454

However, the last sprockets-rails release was in 2017, so we grab it
from GitHub. It's pinned to the earliest ref that includes that PR so
that we don't always grab the latest master (which is a shifting target
and could introduce instability).
@renchap
Copy link

@renchap renchap commented Jul 30, 2020

Would it be possible to have a new release of this gem so we do not need to install from git to get this Ruby 2.7 fix?
The last release was 3 years ago, it would be a good thing to properly release the recent changes to everybody (ping @rafaelfranca)

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Labels
None yet
Projects
None yet
Development

Successfully merging this pull request may close these issues.

None yet

3 participants