This repository has been archived by the owner. It is now read-only.

superclass mismatch for class ParameterMissing #45

Closed
olivierlacan opened this Issue Oct 12, 2012 · 2 comments

Comments

Projects
None yet
2 participants

As soon as I add the strong_parameters gem (0.1.4) to a 4.0.0.beta app, bundle and restart, this is thrown:

TypeError: superclass mismatch for class ParameterMissing
Owner

rafaelfranca commented Oct 12, 2012

You should not add this gem as dependency of a rails 4 application since it is already in the rails code. I'll leave this open to remember to change the gemspec to not allow this gem to be installed in a rails 4 application

@ghost ghost assigned rafaelfranca Oct 12, 2012

Noted, I assumed I would see it in my Gemfile.lock as a dependency, since I didn't see it, I tried to shove it in.

Didn't realize it was not incorporated as a gem.

On Oct 12, 2012, at 3:40 PM, Rafael Mendonça França notifications@github.com wrote:

You should not add this gem as dependency of a rails 4 application since it is already in the rails code. I'll leave this open to remember to change the gemspec to not allow this gem to be installed in a rails 4 application


Reply to this email directly or view it on GitHub.

Sign up for free to subscribe to this conversation on GitHub. Already have an account? Sign in.