Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP
Browse files

fulcrum-agile#70

1. Changed Gemfile and config/environments/development.rb to
   implement letter_opener at https://github.com/ryanb/letter_opener.

2. See 2 SASS::Compiler warnings associated with compass.
   Probably need compass 0.12-alpha.

3. See 1 "Unable to import CSV" error - need to change "on" to "in".
   Will log this fix separately.

4. See 1 jasmine error - expected "2011/09/19 02:25:56" but got
   "19 Sep 2011, 10:25am".  Using Chrome.
  • Loading branch information...
commit d55c54f23b4da6a409c8289a7ece407e45ad0f1d 1 parent 0273732
@jasnow jasnow authored
Showing with 28 additions and 18 deletions.
  1. +1 −0  Gemfile
  2. +23 −16 Gemfile.lock
  3. +4 −2 config/environments/development.rb
View
1  Gemfile
@@ -47,4 +47,5 @@ gem 'compass', '>= 0.11.5'
group :development, :test do
gem 'factory_girl_rails'
gem 'jasmine', '1.1.0'
+ gem "letter_opener"
end
View
39 Gemfile.lock
@@ -28,13 +28,14 @@ GEM
activemodel (= 3.0.11)
activesupport (= 3.0.11)
activesupport (3.0.11)
+ addressable (2.2.6)
arel (2.0.10)
bcrypt-ruby (2.1.4)
builder (2.1.2)
cancan (1.6.1)
- childprocess (0.2.2)
+ childprocess (0.2.3)
ffi (~> 1.0.6)
- chunky_png (1.2.0)
+ chunky_png (1.2.5)
compass (0.11.5)
chunky_png (~> 1.2)
fssm (>= 0.2.7)
@@ -46,12 +47,13 @@ GEM
diff-lcs (1.1.3)
erubis (2.6.6)
abstract (>= 1.0.0)
- factory_girl (1.3.3)
- factory_girl_rails (1.0.1)
- factory_girl (~> 1.3)
+ factory_girl (2.3.2)
+ activesupport
+ factory_girl_rails (1.4.0)
+ factory_girl (~> 2.3.0)
railties (>= 3.0.0)
fastercsv (1.5.3)
- ffi (1.0.9)
+ ffi (1.0.11)
fssm (0.2.7)
i18n (0.5.0)
jasmine (1.1.0)
@@ -60,14 +62,18 @@ GEM
rspec (>= 1.3.1)
selenium-webdriver (>= 0.1.3)
jasmine-core (1.1.0)
- json (1.6.1)
- json_pure (1.5.2)
+ json (1.6.3)
+ launchy (2.0.5)
+ addressable (~> 2.2.6)
+ letter_opener (0.0.2)
+ launchy
mail (2.2.19)
activesupport (>= 2.3.6)
i18n (>= 0.4.0)
mime-types (~> 1.16)
treetop (~> 1.4.8)
mime-types (1.17.2)
+ multi_json (1.0.4)
orm_adapter (0.0.5)
polyglot (0.3.3)
rack (1.2.4)
@@ -96,18 +102,18 @@ GEM
rspec-core (~> 2.7.0)
rspec-expectations (~> 2.7.0)
rspec-mocks (~> 2.7.0)
- rspec-core (2.7.0)
+ rspec-core (2.7.1)
rspec-expectations (2.7.0)
diff-lcs (~> 1.1.2)
rspec-mocks (2.7.0)
- rubyzip (0.9.4)
- sass (3.1.5)
- selenium-webdriver (2.8.0)
+ rubyzip (0.9.5)
+ sass (3.1.11)
+ selenium-webdriver (2.15.0)
childprocess (>= 0.2.1)
- ffi (>= 1.0.7)
- json_pure
+ ffi (~> 1.0.9)
+ multi_json (~> 1.0.4)
rubyzip
- sqlite3 (1.3.3)
+ sqlite3 (1.3.5)
sqlite3-ruby (1.3.3)
sqlite3 (>= 1.3.3)
thor (0.14.6)
@@ -116,7 +122,7 @@ GEM
polyglot
polyglot (>= 0.3.1)
tzinfo (0.3.31)
- warden (1.0.4)
+ warden (1.0.6)
rack (>= 1.0)
PLATFORMS
@@ -129,6 +135,7 @@ DEPENDENCIES
factory_girl_rails
fastercsv (= 1.5.3)
jasmine (= 1.1.0)
+ letter_opener
rails (= 3.0.11)
sqlite3-ruby
transitions (= 0.0.9)
View
6 config/environments/development.rb
@@ -15,8 +15,8 @@
config.action_controller.perform_caching = false
# Don't care if the mailer can't send
- config.action_mailer.perform_deliveries = false
- config.action_mailer.raise_delivery_errors = false
+ config.action_mailer.perform_deliveries = true
+ config.action_mailer.raise_delivery_errors = true
config.action_mailer.default_url_options = { :host => '127.0.0.1:3000' }
# Print deprecation notices to the Rails logger
@@ -24,5 +24,7 @@
# Only use best-standards-support built into browsers
config.action_dispatch.best_standards_support = :builtin
+
+ config.action_mailer.delivery_method = :letter_opener
end
Please sign in to comment.
Something went wrong with that request. Please try again.