What you should change about your app's configuration when upgrading Rails versions
JavaScript HTML CSS
Switch branches/tags
Nothing to show
Clone or download
Fetching latest commit…
Cannot retrieve the latest commit at this time.
Permalink
Failed to load latest commit information.
app
config
public
tests
vendor
.editorconfig
.ember-cli
.eslintrc.js
.gitignore
.travis.yml
.watchmanconfig
LICENSE.md
README.md
ember-cli-build.js
package.json
testem.js
yarn.lock

README.md

RailsDiff

This is the Ember CLI app powering http://railsdiff.org, this app gets its data from an API. If you are wanting to make UI changes then you are in the right place; if on the other hand, you want to make changes to its data, head over to the API repository instead.

Prerequisites

You will need the following things properly installed on your computer.

Installation

  • git clone https://github.com/railsdiff/railsdiff.git this repository
  • cd rails-diff
  • npm install

Running / Development

Code Generators

Make use of the many generators for code, try ember help generate for more details

Running Tests

  • ember test
  • ember test --server

Building

  • ember build (development)
  • ember build --environment production (production)

Further Reading / Useful Links