Browse files

upgrades tests to use i18n for 'logged in as'. updates spree_auth_dev…

…ise until gem version issue is resolved
  • Loading branch information...
1 parent c1f78c0 commit 1cc3adb0511e9a703b5a1dc31118f70cc0da7dc6 @jsqu99 jsqu99 committed Jan 30, 2013
Showing with 12 additions and 6 deletions.
  1. +4 −0 Gemfile
  2. +2 −2 spec/features/normal_admin_users_spec.rb
  3. +2 −2 spec/features/super_admin_users_spec.rb
  4. +4 −2 spree_landlord.gemspec
View
4 Gemfile
@@ -2,6 +2,10 @@ source 'http://rubygems.org'
gem 'spree', '~> 1.3.1'
gem 'spree_sample', '~> 1.3.1'
+
+# TODO: uncomment when https://github.com/spree/spree_auth_devise/issues/53 is resolved
+# gem version 1.3.1 isn't really 1.3.1
+#gem 'spree_auth_devise', '~> 1.3.1'
gem 'spree_auth_devise', github: 'spree/spree_auth_devise', branch: '1-3-stable'
gem 'rspec-rails'
View
4 spec/features/normal_admin_users_spec.rb
@@ -30,7 +30,7 @@
click_button 'Login'
page.should_not have_content('Invalid email or password')
- page.should have_content("Logged in as: #{apples_admin.email}")
+ page.should have_content("#{I18n.t(:logged_in_as)}: #{apples_admin.email}")
end
it 'cannot log into a different tenant' do
@@ -41,7 +41,7 @@
click_button 'Login'
page.should have_content('Invalid email or password')
- page.should_not have_content("Logged in as: #{apples_admin.email}")
+ page.should_not have_content("#{I18n.t(:logged_in_as)}: #{apples_admin.email}")
end
it 'cannot create a super admin' do
View
4 spec/features/super_admin_users_spec.rb
@@ -36,7 +36,7 @@
click_button 'Login'
page.should_not have_content('Invalid email or password')
- page.should have_content("Logged in as: #{super_admin.email}")
+ page.should have_content("#{I18n.t(:logged_in_as)}: #{super_admin.email}")
end
it 'can log into the tenant backend it does not belong to' do
@@ -47,7 +47,7 @@
click_button 'Login'
page.should_not have_content('Invalid email or password')
- page.should have_content("Logged in as: #{super_admin.email}")
+ page.should have_content("#{I18n.t(:logged_in_as)}: #{super_admin.email}")
end
it 'can create super admin users' do
View
6 spree_landlord.gemspec
@@ -16,8 +16,10 @@ Gem::Specification.new do |s|
s.requirements << 'none'
s.add_dependency 'spree_core', '~> 1.3.1'
-# TODO: uncomment when we get a fixed published version
-# s.add_dependency 'spree_auth_devise', '~> 1.3.1'
+
+ # TODO: uncomment when https://github.com/spree/spree_auth_devise/issues/53 is resolved
+ # gem version 1.3.1 isn't really 1.3.1
+ # s.add_dependency 'spree_auth_devise', '~> 1.3.1'
s.add_dependency 'spree_promo', '~> 1.3.1'
s.add_development_dependency 'ffaker', '~> 1.12.1'

0 comments on commit 1cc3adb

Please sign in to comment.