Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP
Moonshine Plugin to Install Prince XML
Ruby

Fetching latest commit…

Cannot retrieve the latest commit at this time

Failed to load latest commit information.
lib/moonshine
moonshine
readme.markdown

readme.markdown

Moonshine::Prince

Introduction

Welcome to Moonshine::Prince, a Moonshine plugin for installing and managing Prince XML.

Here's some quick links:

Quick Start

Moonshine::Prince is installed as a Rails plugin:

# Rails 2.x.x
script/plugin install git://github.com/railsmachine/moonshine_prince.git
# Rails 3.x.x
script/rails plugin install git://github.com/railsmachine/moonshine_prince.git
# Rails 4.x.x
Add <code>gem 'plugger'</code> to your Gemfile and bundle install, then:
plugger install git://github.com/railsmachine/moonshine_prince.git

Once it's installed, you can include it in your manifest:

# app/manifests/application_manifest.rb
class ApplicationManifest < Moonshine::Manifest:Rails

   # other recipes and configuration omitted

   # tell ApplicationManifest to use the prince recipe
   recipe :prince
end

Configuration Options

Configure the version in your moonshine.yml:

:prince:
  :version: 9.0 

or in your manifest;

configure(:prince => {:version => '9.0'})

Dependencies

Copyright

Unless otherwise specified, all content copyright © 2014, Rails Machine, LLC

Something went wrong with that request. Please try again.