Skip to content
Browse files

ruby version

  • Loading branch information...
1 parent add0585 commit be6a07063f702ae986e978006a9d1e33905f4263 @le0pard le0pard committed Mar 18, 2013
Showing with 12 additions and 23 deletions.
  1. +1 −14 Rakefile
  2. +0 −1 VERSION
  3. +5 −6 js-routes.gemspec
  4. +3 −2 lib/js_routes.rb
  5. +3 −0 lib/js_routes/version.rb
View
15 Rakefile
@@ -9,20 +9,7 @@ rescue Bundler::BundlerError => e
$stderr.puts "Run `bundle install` to install missing gems"
exit e.status_code
end
-require 'rake'
-
-require 'jeweler'
-Jeweler::Tasks.new do |gem|
- gem.name = "js-routes"
- gem.homepage = "http://github.com/railsware/js-routes"
- gem.license = "MIT"
- gem.summary = %Q{Brings Rails named routes to javascript}
- gem.description = %Q{Generates javascript file that defines all Rails named routes as javascript helpers}
- gem.email = "agresso@gmail.com"
- gem.authors = ["Bogdan Gusiev"]
- # dependencies defined in Gemfile
-end
-Jeweler::RubygemsDotOrgTasks.new
+require 'bundler/gem_tasks'
require 'rspec/core'
require 'rspec/core/rake_task'
View
1 VERSION
@@ -1 +0,0 @@
-0.9.0
View
11 js-routes.gemspec
@@ -1,11 +1,11 @@
-# Generated by jeweler
-# DO NOT EDIT THIS FILE DIRECTLY
-# Instead, edit Jeweler::Tasks in Rakefile, and run 'rake gemspec'
-# -*- encoding: utf-8 -*-
+# coding: utf-8
+lib = File.expand_path('../lib', __FILE__)
+$LOAD_PATH.unshift(lib) unless $LOAD_PATH.include?(lib)
+require 'js_routes/version'
Gem::Specification.new do |s|
s.name = %q{js-routes}
- s.version = "0.8.7"
+ s.version = JsRoutes::VERSION
s.required_rubygems_version = Gem::Requirement.new(">= 0") if s.respond_to? :required_rubygems_version=
s.authors = ["Bogdan Gusiev"]
@@ -26,7 +26,6 @@ Gem::Specification.new do |s|
s.add_development_dependency(%q<therubyracer>, [">= 0"])
s.add_development_dependency(%q<rspec>, ["~> 2.10.0"])
s.add_development_dependency(%q<bundler>, [">= 1.1.0"])
- s.add_development_dependency(%q<jeweler>, ["~> 1.6.2"])
s.add_development_dependency(%q<guard>, [">= 0"])
s.add_development_dependency(%q<rb-fsevent>, [">= 0"])
s.add_development_dependency(%q<guard-coffeescript>, [">= 0"])
View
5 lib/js_routes.rb
@@ -1,3 +1,4 @@
+require 'js_routes/version'
class JsRoutes
#
@@ -93,9 +94,9 @@ def generate
end
def deprecated_default_format
- if @options.key?(:default_format)
+ if @options.key?(:default_format)
warn("default_format option is deprecated. Use default_url_options = {:format => <format>} instead")
- {:format => @options[:default_format]}
+ {:format => @options[:default_format]}
else
{}
end
View
3 lib/js_routes/version.rb
@@ -0,0 +1,3 @@
+class JsRoutes
+ VERSION = "0.8.7"
+end

0 comments on commit be6a070

Please sign in to comment.
Something went wrong with that request. Please try again.