Skip to content
Browse files

Merge pull request #192 from railsware/fix_deps

Added ruby 2.3 for testing, fixed deps for ruby < 2.2 (removed guard, which is not used)
  • Loading branch information...
2 parents e100750 + a614213 commit dc5ae21a3d1e490db434c19469cd6138f35f66fc @bogdan bogdan committed May 20, 2016
Showing with 3 additions and 8 deletions.
  1. +1 −0 .travis.yml
  2. +0 −3 Guardfile
  3. +1 −2 js-routes.gemspec
  4. +1 −1 spec/spec_helper.rb
  5. +0 −2 temp
View
1 .travis.yml
@@ -6,6 +6,7 @@ rvm:
- 2.0
- 2.1
- 2.2
+ - 2.3.1
- jruby-19mode
- ruby-head
- jruby-head
View
3 Guardfile
@@ -1,3 +0,0 @@
-guard 'coffeescript', :output => 'lib', :all_on_start => true do
- watch(%r{^lib/(.+\.coffee)$})
-end
View
3 js-routes.gemspec
@@ -24,8 +24,7 @@ Gem::Specification.new do |s|
s.add_runtime_dependency(%q<sprockets-rails>)
s.add_development_dependency(%q<rspec>, [">= 3.0.0"])
s.add_development_dependency(%q<bundler>, [">= 1.1.0"])
- s.add_development_dependency(%q<guard>, [">= 0"])
- s.add_development_dependency(%q<guard-coffeescript>, [">= 0"])
+ s.add_development_dependency(%q<coffee-script>, [">= 0"])
s.add_development_dependency(%q<appraisal>, [">= 0.5.2"])
if defined?(JRUBY_VERSION)
s.add_development_dependency(%q<therubyrhino>, [">= 2.0.4"])
View
2 spec/spec_helper.rb
@@ -5,7 +5,7 @@
require 'rspec'
require 'rails/all'
require 'js-routes'
-require "active_support/core_ext/hash/slice"
+require 'active_support/core_ext/hash/slice'
require 'coffee-script'
# fix ends_with? error for rails 3.2
require 'active_support/core_ext/string/starts_ends_with' if 3 == Rails::VERSION::MAJOR
View
2 temp
@@ -1,2 +0,0 @@
-#<ActionDispatch::Journey::Route:0x007f8c4bdba798 @name="blog_app", @app=BlogEngine::Engine, @path=#<ActionDispatch::Journey::Path::Pattern:0x007f8c4bdbb120 @anchored=false, @spec=/blog, @requirements={}, @separators="/.?", @names=[], @optional_names=[], @required_names=[], @re=nil, @offsets=nil>, @dispatcher=false, @constraints={:required_defaults=>[]}, @defaults={}, @required_defaults=nil, @required_parts=[], @parts=[], @decorated_ast=nil, @precedence=61>
-#<ActionDispatch::Journey::Route:0x007f8c4a861658 @name="support", @app=BlogEngine::Engine, @path=#<ActionDispatch::Journey::Path::Pattern:0x007f8c4a85c838 @anchored=true, @spec=/support(/page/:page)(.:format), @requirements={}, @separators="/.?", @names=["page", "format"], @optional_names=["page", "format"], @required_names=[], @re=nil, @offsets=nil>, @dispatcher=false, @constraints={:required_defaults=>[], :request_method=>/^GET$/}, @defaults={}, @required_defaults=nil, @required_parts=[], @parts=[:page, :format], @decorated_ast=nil, @precedence=0>

0 comments on commit dc5ae21

Please sign in to comment.
Something went wrong with that request. Please try again.