Permalink
Switch branches/tags
Find file
Fetching contributors…
Cannot retrieve contributors at this time
70 lines (64 sloc) 2.23 KB
# Generated by jeweler
# DO NOT EDIT THIS FILE DIRECTLY
# Instead, edit Jeweler::Tasks in Rakefile, and run 'rake gemspec'
# -*- encoding: utf-8 -*-
Gem::Specification.new do |s|
s.name = %q{auto_do_something}
s.version = "0.1.1"
s.required_rubygems_version = Gem::Requirement.new(">= 0") if s.respond_to? :required_rubygems_version=
s.authors = ["ayaya"]
s.date = %q{2011-01-25}
s.description = %q{A simple Ruby on Rails plugin to let model auto do something (like strip, downcase, etc.) before validation.}
s.email = %q{ayaya@aya.idv.tw}
s.extra_rdoc_files = [
"LICENSE.txt",
"README.rdoc"
]
s.files = [
".document",
".rspec",
"Gemfile",
"Gemfile.lock",
"LICENSE.txt",
"README.rdoc",
"Rakefile",
"VERSION",
"auto_do_something.gemspec",
"init.rb",
"lib/auto_do_something.rb",
"spec/auto_do_something_spec.rb",
"spec/spec_helper.rb"
]
s.homepage = %q{http://github.com/ayamomiji/auto_do_something}
s.licenses = ["MIT"]
s.require_paths = ["lib"]
s.rubygems_version = %q{1.3.7}
s.summary = %q{A simple Ruby on Rails plugin to let model auto do something before validation.}
s.test_files = [
"spec/auto_do_something_spec.rb",
"spec/spec_helper.rb"
]
if s.respond_to? :specification_version then
current_version = Gem::Specification::CURRENT_SPECIFICATION_VERSION
s.specification_version = 3
if Gem::Version.new(Gem::VERSION) >= Gem::Version.new('1.2.0') then
s.add_runtime_dependency(%q<activemodel>, ["~> 3.0"])
s.add_development_dependency(%q<rspec>, ["~> 2.4.0"])
s.add_development_dependency(%q<bundler>, ["~> 1.0.0"])
s.add_development_dependency(%q<jeweler>, ["~> 1.5.2"])
s.add_development_dependency(%q<rcov>, [">= 0"])
else
s.add_dependency(%q<activemodel>, ["~> 3.0"])
s.add_dependency(%q<rspec>, ["~> 2.4.0"])
s.add_dependency(%q<bundler>, ["~> 1.0.0"])
s.add_dependency(%q<jeweler>, ["~> 1.5.2"])
s.add_dependency(%q<rcov>, [">= 0"])
end
else
s.add_dependency(%q<activemodel>, ["~> 3.0"])
s.add_dependency(%q<rspec>, ["~> 2.4.0"])
s.add_dependency(%q<bundler>, ["~> 1.0.0"])
s.add_dependency(%q<jeweler>, ["~> 1.5.2"])
s.add_dependency(%q<rcov>, [">= 0"])
end
end