Skip to content
open-source implementation of PHIN requirements
Pull request Compare This branch is 2336 commits behind talho:master.
Fetching latest commit…
Cannot retrieve the latest commit at this time.
Failed to load latest commit information.
app
config
db
doc
externals/firefox_portable
features
lib
manual_features
message_recordings
public
script
spec
vendor/plugins
.gitignore
.gitmodules
.project
Capfile
README
Rakefile
agpl-3.0.txt
cucumber.yml

README

== OpenPHIN

== Prerequisites 

1. Sphinx http://freelancing-god.github.com/ts/en/installing_sphinx.html
2. MySQL or PostgreSQL database
3. Ruby 1.8.6
4. RubyGems
5. Rails 2.3
6. Git (not required to run, but well help getting it installed)


== Running the app

1. git submodule update --init
2. rake gems:install
3. rake db:migrate
4. rake db:seed  # build some base data
5. script/server


== Running Tests

1. rake gems:install RAILS_ENV=cucumber
2. rake  # Run the RSpec specs
3. rake features  # run the cucumber features
Something went wrong with that request. Please try again.