Permalink
Browse files

Fixed strict ruby_version requirement.

(It doesn't play nice with fat binaries installation).
  • Loading branch information...
1 parent 2d9d29a commit 34f0776013d30528d0462ea9e2ef6666f2607a5b @luislavena luislavena committed May 31, 2009
Showing with 5 additions and 5 deletions.
  1. +5 −0 History.txt
  2. +0 −5 lib/rake/extensiontask.rb
View
@@ -23,6 +23,11 @@
rake-compiler cross-ruby VERSION=1.9.1-p0 SOURCE=http://ftp.ruby-lang.org/pub/ruby/1.9/ruby-1.9.1-p0.tar.bz2
+* Bugfixes
+ * Removed strict versioning for gems since it clash with fat binaries.
+ From now on, if your gem only targets a specific version of Ruby, please
+ indicate it in the Gem::Specification (<tt>required_ruby_version</tt>)
+
=== 0.5.0 / 2009-04-25
* Enhancements
@@ -197,11 +197,6 @@ def define_native_tasks(for_platform = nil, ruby_ver = RUBY_VERSION)
# include the files in the gem specification
spec.files += ext_files
- # Make sure that the required ruby version matches the ruby version
- # we've used for cross compiling:
- target_version = RUBY_VERSION =~ /^1.8/ ? '1.8.6' : '1.9.0'
- spec.required_ruby_version = "~> #{target_version}"
-
# Generate a package for this gem
gem_package = Rake::GemPackageTask.new(spec) do |pkg|
pkg.need_zip = false

0 comments on commit 34f0776

Please sign in to comment.