Skip to content
Permalink
Browse files

Make sure %REQUIRE_SYMBOLS doesn't get lowered

  • Loading branch information...
jnthn committed Nov 1, 2018
1 parent b41e9f5 commit b0e7e375d1ec8c76e20f3617b56783a15a1febc5
Showing with 1 addition and 0 deletions.
  1. +1 −0 src/Perl6/Actions.nqp
@@ -2162,6 +2162,7 @@ class Perl6::Actions is HLL::Actions does STDActions {
$block := $*W.blocks[+$*W.blocks - 2] if $block.HOW.name($block) eq 'Code';
if !$lexpad.symbol('%REQUIRE_SYMBOLS') {
declare_variable($/, $past, '%', '', 'REQUIRE_SYMBOLS', []);
$*W.mark_lexical_used_implicitly($lexpad, '%REQUIRE_SYMBOLS');
}
my $require_past := WANTED(QAST::Op.new(:node($/), :op<call>,
:name<&REQUIRE_IMPORT>,

0 comments on commit b0e7e37

Please sign in to comment.
You can’t perform that action at this time.