Skip to content
Permalink
Browse files

Require Java 9 for JVM backend

  • Loading branch information...
usev6 committed May 14, 2019
1 parent bd89d51 commit ea94966da3ed94f5fa1229a2921ff388c88943ae
Showing with 2 additions and 2 deletions.
  1. +1 −1 .travis.yml
  2. +1 −1 tools/templates/jvm/Makefile.in
@@ -21,7 +21,7 @@ addons:
- gcc-6

script:
- if [[ $TRAVIS_OS_NAME != osx && $RAKUDO_OPTIONS =~ jvm ]]; then sudo -E apt-get install oracle-java8-installer; fi
- if [[ $TRAVIS_OS_NAME != osx && $RAKUDO_OPTIONS =~ jvm ]]; then sudo -E apt-get install oracle-java9-installer; fi
- perl Configure.pl $RAKUDO_OPTIONS --moar-option=--cc=$(command -v gcc-6 >/dev/null 2>&1; if [ $? -eq 1 ]; then printf "gcc"; else printf "gcc-6"; fi)
- "make install"
- (cd ~/build/rakudo/rakudo/ && prove -e ~/build/rakudo/rakudo/install/bin/perl6 -vlr t)
@@ -90,7 +90,7 @@ check_@backend_prefix@_nqp_version: @@script(check-nqp-version.pl)@@

$(RUNTIME_JAR): $(RUNTIME_JAVAS)
$(MKPATH) bin
$(JAVAC) -source 1.8 -cp @q($(BLD_NQP_JARS))@ -g -d bin -encoding UTF8 $(RUNTIME_JAVAS)
$(JAVAC) -source 1.9 -cp @q($(BLD_NQP_JARS))@ -g -d bin -encoding UTF8 $(RUNTIME_JAVAS)
$(JAR) cf0 rakudo-runtime.jar -C bin@slash@ .

$(PERL6_ML_JAR): @nfpl(src/Perl6/ModuleLoader.nqp src/vm/jvm/ModuleLoaderVMConfig.nqp src/vm/jvm/Perl6/JavaModuleLoader.nqp gen/nqp-version)@

0 comments on commit ea94966

Please sign in to comment.
You can’t perform that action at this time.