Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP
branch: master
Fetching contributors…

Cannot retrieve contributors at this time

58 lines (52 sloc) 1.579 kb
require 'rake'
require 'rake/testtask'
require 'rake/clean'
begin
require 'jeweler'
Jeweler::Tasks.new do |gemspec|
gemspec.name = "fluent-plugin-flume"
gemspec.summary = "Flume Input/Output plugin for Fluentd event collector"
gemspec.author = "Muga Nishizawa"
gemspec.email = "muga.nishizawa@gmail.com"
gemspec.homepage = "https://github.com/muga/fluent-plugin-flume"
gemspec.has_rdoc = false
gemspec.require_paths = ["lib"]
gemspec.add_dependency "fluentd", "~> 0.10.16"
gemspec.add_dependency "thrift", "~> 0.8.0"
gemspec.test_files = Dir["test/**/*.rb"]
gemspec.files = Dir["bin/**/*", "lib/**/*", "test/**/*.rb"] +
%w[example.conf VERSION AUTHORS Rakefile fluent-plugin-flume.gemspec]
gemspec.executables = ['fluent-flume-remote']
end
Jeweler::GemcutterTasks.new
rescue LoadError
puts "Jeweler not available. Install it with: gem install jeweler"
end
task "thrift_gen" do
system "mkdir -p tmp"
system "thrift --gen rb -o tmp lib/fluent/plugin/thrift/flume.thrift"
system "mv tmp/gen-rb/* lib/fluent/plugin/thrift/"
system "rm -fR tmp"
end
Rake::TestTask.new(:test) do |t|
t.test_files = Dir['test/plugin/*.rb']
t.ruby_opts = ['-rubygems'] if defined? Gem
t.ruby_opts << '-I.'
end
#VERSION_FILE = "lib/fluent/version.rb"
#
#file VERSION_FILE => ["VERSION"] do |t|
# version = File.read("VERSION").strip
# File.open(VERSION_FILE, "w") {|f|
# f.write <<EOF
#module Fluent
#
#VERSION = '#{version}'
#
#end
#EOF
# }
#end
#
#task :default => [VERSION_FILE, :build]
task :default => [:build]
Jump to Line
Something went wrong with that request. Please try again.