Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with
or
.
Download ZIP

Loading…

crosslet example not working #1

Closed
lcolladotor opened this Issue · 26 comments

10 participants

@lcolladotor

Hello,

I'm not sure if I'm doing something wrong or missing any pre-reqs, but the CrossLet example is not working for me.

> sessionInfo()
R version 3.0.2 (2013-09-25)
Platform: x86_64-apple-darwin10.8.0 (64-bit)

locale:
[1] en_US.UTF-8/en_US.UTF-8/en_US.UTF-8/C/en_US.UTF-8/en_US.UTF-8

attached base packages:
[1] stats     graphics  grDevices utils     datasets  methods   base     

other attached packages:
[1] rMaps_0.1

loaded via a namespace (and not attached):
[1] grid_3.0.2         lattice_0.20-24    plyr_1.8           rCharts_0.4.2     
[5] RColorBrewer_1.0-5 rjson_0.2.13       RJSONIO_1.0-3      whisker_0.3-2     
[9] yaml_2.1.10       

Here's the screenshot from the Google Chrome console.

screen shot 2014-02-10 at 10 32 54 am

DataMaps and Leaflet examples are working well.

Cheers,
Leo

@ramnathv
Owner

Did you install the dev version of rCharts?

@ramnathv
Owner

You will need a local server to preview crosslet maps, since it reads JSON. If you are using the latest version of RStudio, it will automatically open the map up in a server for you.

@lcolladotor

Yes, I did install the dev version of rCharts. By the way, have you tried using different version numbers for dev and release versions of rCharts? That way you can tell which version the user is using from the sessionInfo. Here's a versioning system that might be useful http://www.bioconductor.org/developers/package-guidelines/#versions

Ok, I didn't know about the local server part. And like you said, it does work in RStudio. Thanks!

@ramnathv
Owner

My version control is a little messed up right now. Locally, I am working with only a single branch. I keep pushing to dev till ideas are stable and then merge back with master. I need a more robust git workflow :)

@ramnathv ramnathv added the crosslet label
@arturochian

It's working fine. You have to install the dev version as ramnathv said. I recommend uninstalling the old version using remove.packages("rCharts")
It's very nice. :)
The next month I'm going to learn how to configurate that. I'm interested in geolocalization for social variables.
I'm thinking integration with WDI package could be great. There are a lot of economics information about countries.

@ramnathv
Owner

Yes. The WDI package provides some nice data that can be used with rMaps. Let me know any comments/feedback that you have as you try things out.

@arturochian

Sure, I'm improving my Shiny's skills for this month. I'm interested doing the same for my country Peru by cities for next months for improving economics decisions.

PD: I'm student in Economics so these things are interesting for me.
Best regards

@lcolladotor

As Ramnath said, it works with RStudio. I just removed and installed the dev version of rChartsand ran into the same issue as before when using the R GUI instead of RStudio.

screen shot 2014-02-10 at 11 11 57 am

@arturochian

Try

x<-crosslet(
  x = "country", 
  y = c("web_index", "universal_access", "impact_empowerment", "freedom_openness"),
  data = web_index
)
print(x)
@lcolladotor

Tried it, got the same result on the R GUI.

This has to be related to the local server Ramnath mentioned earlier.

@arturochian

I see, It's about that.
Interesting...
I didn't know that differences...

@patilv

The examples worked for me, verbatim. Using R-Studio, v 0.98.490.

@ramnathv
Owner

Crosslet will only work in RStudio for now. I have to figure out a way to make it work from the R GUI.

@ramnathv ramnathv closed this
@abresler

Mine stopped working on R-Studio - just upgraded to 0.98.501 not sure whats going on

@ramnathv
Owner

I am on 0.98.637 and it works fine for me. Let me check what is happening with 0.98.501

@abresler
@ramnathv
Owner

Yes. I am on a mac. Just go to the page with daily builds

http://www.rstudio.org/download/daily/desktop/mac/

@abresler
@abresler

Works perfectly - its something with 0.98.501 but the preview works perfectly!

@patilv

I have .98.501 on Windows. Works fine.

@lcolladotor

I'm using .98.501 on Mac and it works fine there too.

screen shot 2014-02-12 at 1 29 34 pm

@dg83

Hi,

I am running into the same issues as lcolladotor. Cannot see the crosslet maps but leaflet and datamaps work fine. I have the latest version of Rstudio and Windows 8.1

Thanks

@bhuston

Ditto on what dg83 said. I'm running Windows 8.1/Chrome/Rstudio 0.98.1091 and I cannot get map in crosslet to display either in the viewer or in my broswer.

2014-12-03 22_50_19-localhost_11354_session_rcharts10b457733b78_index

@cantgetthatping
@geertdobbels

Hi,

I get exactly the same results as bhuston above.... labels appear but no map.
I am on Linux fedora 21,
R version 3.1.3
Rstudio 0.99.386 (updated recently, but in previous version I had the same problem)
As with the others, the datamap and leaflet examples work fine.

Geert

@JasonAizkalns

I receive the same results as @bhuston @cantgetthatping and @geertdobbels - I am able to see the labels/controls, but no map.

Here's the output from the Chrome console:

image

The 403 status messages continue and they appear to come back with Wrong API Key.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Something went wrong with that request. Please try again.