Skip to content
Newer
Older
100644 34 lines (29 sloc) 1.41 KB
cbfcf56 @randym restructuring lib and adding 1.9.2 to travis
authored
1 require File.expand_path(File.dirname(__FILE__) + '/lib/acts_as_xlsx/version.rb')
2
4313c6c @randym pre-release
authored
3 Gem::Specification.new do |s|
4 s.name = 'acts_as_xlsx'
cbfcf56 @randym restructuring lib and adding 1.9.2 to travis
authored
5 s.version = Axlsx::Ar::VERSION
4313c6c @randym pre-release
authored
6 s.author = "Randy Morgan"
7 s.email = 'digital.ipseity@gmail.com'
8 s.homepage = 'https://github.com/randym/acts_as_xlsx'
9 s.platform = Gem::Platform::RUBY
10 s.date = Time.now.strftime('%Y-%m-%d')
11 s.summary = "ActiveRecord support for Axlsx"
12 s.has_rdoc = 'acts_as_xlsx'
13 s.description = <<-eof
14 acts_as_xlsx lets you turn any ActiveRecord::Base inheriting class into an excel spreadsheet.
2b9baa4 @randym 1.0.4 prep New features for adding to_xlsx results to an existing pac…
authored
15 It can be added to any finder method or scope chain and can use localized column and sheet names with I18n.
4313c6c @randym pre-release
authored
16 eof
2b9baa4 @randym 1.0.4 prep New features for adding to_xlsx results to an existing pac…
authored
17 s.files = Dir.glob("{lib/**/*}") + %w{ LICENSE README.md Rakefile CHANGELOG.md .yardopts }
18 s.test_files = Dir.glob("{test/**/*}")
cbfcf56 @randym restructuring lib and adding 1.9.2 to travis
authored
19
2b9baa4 @randym 1.0.4 prep New features for adding to_xlsx results to an existing pac…
authored
20 s.add_runtime_dependency 'axlsx', '>= 1.0.13'
0b54701 @randym patch for inclusion problem, and reverting dependencies to play nicel…
authored
21 s.add_runtime_dependency 'activerecord', '>= 2.3.9'
abc8fc2 @randym bump and alter dependencies to declare 18n internally
authored
22 s.add_runtime_dependency 'i18n', '>= 0.4.1'
23
2b9baa4 @randym 1.0.4 prep New features for adding to_xlsx results to an existing pac…
authored
24 s.add_development_dependency 'rake', "0.8.7" if RUBY_VERSION == "1.9.2"
25 s.add_development_dependency 'rake', "~> 0.9" if ["1.9.3", "1.8.7"].include?(RUBY_VERSION)
cbfcf56 @randym restructuring lib and adding 1.9.2 to travis
authored
26 s.add_development_dependency 'bundler'
f1e6d28 @randym patching the version of sqlite dev dependency
authored
27 s.add_development_dependency 'sqlite3', "~> 1.3.5"
cbfcf56 @randym restructuring lib and adding 1.9.2 to travis
authored
28 s.add_development_dependency 'yard'
29 s.add_development_dependency 'rdiscount'
3df2288 @randym beginnings of specs. Pushing to get this working on travis first.
authored
30
b31440b @randym recursive rake inclusion....
authored
31 s.required_ruby_version = '>= 1.8.7'
32 s.require_path = 'lib'
4313c6c @randym pre-release
authored
33 end
Something went wrong with that request. Please try again.