Permalink
Browse files

windows: support RubyInstaller 2.4 or later

[groonga-dev,04565]

Reported by ongaeshi. Thanks!!!
  • Loading branch information...
kou committed Jan 25, 2018
1 parent 93b6278 commit 5f37d5c0a9b28155b5d56a590243239097343c65
Showing with 8 additions and 3 deletions.
  1. +8 −3 lib/groonga.rb
@@ -1,6 +1,4 @@
# -*- coding: utf-8 -*-
#
# Copyright (C) 2009-2013 Kouhei Sutou <kou@clear-code.com>
# Copyright (C) 2009-2018 Kouhei Sutou <kou@clear-code.com>
#
# This library is free software; you can redistribute it and/or
# modify it under the terms of the GNU Lesser General Public
@@ -32,6 +30,13 @@
end
prepend_path.call("PATH", File::PATH_SEPARATOR)
begin
require "ruby_installer/runtime"
rescue LoadError
else
RubyInstaller::Runtime.add_dll_directory(local_groonga_bin_dir.to_s)
end
end
require "groonga/geo-point"

0 comments on commit 5f37d5c

Please sign in to comment.