NOTE: This is a work in progress. Capybara driver for zombie.js running on top of node.js
Pull request Compare This branch is 5 commits behind plataformatec:master.
Fetching latest commit…
Cannot retrieve the latest commit at this time.
Permalink
Failed to load latest commit information.
lib/capybara
spec
.gitignore
CHANGELOG.rdoc
Gemfile
Gemfile.lock
MIT-LICENSE
README.rdoc
Rakefile
capybara-zombie.gemspec

README.rdoc

capybara-zombie

Description:

capybara-zombie is a Capybara driver for zombie.js. The goal is to have a fast driver with full support to javascript.

NOTE: This gem is in active development and is not ready for use yet.

Install:

Install as a gem:

gem install capybara-zombie

Development:

Using with Capybara

See the Capybara docs. Use the symbol :zombie for the driver/default_driver as appropriate.

If you are using cucumber, you might add the following lines to your features/support/env.rb

require 'capybara/zombie'
Capybara.javascript_driver = :zombie

Acknowledgements

  • zombie.js for putting together a great testing tool on node.js

  • Capybara for the amazing flexibility and test suite

  • capybara-envjs which was used as basis to create this gem

License

See MIT License.

Copyright © 2010 Plataforma Tecnologia (blog.plataformatec.com.br)