Skip to content


Subversion checkout URL

You can clone with
Download ZIP
Branch: unstable
39 lines (25 sloc) 1.12 KB
(Last updated: 2014-03-04)
This document almost entirely deprecated by:
in the same directory as this file, and to a lesser extent:
The Metasploit Development Environment
Common Coding Mistakes
The Ruby Style Guide
Ruby 1.9: What to Expect
You can use the the "./tools/msftidy.rb" script against your new and
changed modules to do some rudimentary checking for various style and
syntax violations.
Licensing for Your New Content
By submitting code contributions to the Metasploit Project it is
assumed that you are offering your code under the Metasploit License
or similar 3-clause BSD-compatible license. MIT and Ruby Licenses
are also fine. We specifically cannot include GPL code. LGPL code
is accepted on a case by case basis for libraries only and is never
accepted for modules.
Jump to Line
Something went wrong with that request. Please try again.