New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Update ruby and docker #85

Merged
merged 2 commits into from Jan 8, 2019

Conversation

Projects
None yet
2 participants
@jmartin-r7
Copy link
Contributor

jmartin-r7 commented Jan 8, 2019

Update ruby to 2.5.3 for the project and inside Dockerfiles to support updated dependency requirements.

Additionally Ubuntu 12.04 docker options are offered here.

Test builds are needed to ensure the locally compiled gawk and sqlite3 packages used inside the kali 1.09 containers are built with proper architectures enforced.

jmartin-r7 added some commits Jan 8, 2019

@busterb

This comment has been minimized.

Copy link
Contributor

busterb commented Jan 8, 2019

We can safely axe Kali 0.9 support if we want to switch to Ubuntu 12.04 as a "more up-to-date" base. It's been a half-decade since the former got any updates I think.

@busterb busterb merged commit 90eb2ce into rapid7:master Jan 8, 2019

busterb added a commit that referenced this pull request Jan 8, 2019

jmartin-r7 added a commit that referenced this pull request Jan 10, 2019

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment