Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Deploying to heroku does not work #221

Closed
dgollahon opened this issue Jul 25, 2016 · 8 comments
Closed

Deploying to heroku does not work #221

dgollahon opened this issue Jul 25, 2016 · 8 comments

Comments

@dgollahon
Copy link

@dgollahon dgollahon commented Jul 25, 2016

First of all, thanks for building this--I've found it useful. Unfortunately it seems like directly deploying to heroku does not work correctly.

It appears to be due to this line, which expects dist/ to exist, but does not by default, since it is ignored from source control.

I was able to work around it, but it was pretty confusing when I first tried to setup the server. It would be great if you could fix this or, at least, provide a better warning when unable to access dist/.

Thanks!

@tonyedwardspz
Copy link

@tonyedwardspz tonyedwardspz commented Jul 25, 2016

@dgollahon I'm having the same issue. How did you work around it? Build locally and then deploy to heroku?

@dgollahon
Copy link
Author

@dgollahon dgollahon commented Jul 25, 2016

@tonyedwardspz: yeah, just checked dist/ into my copy of the repo and pushed that.

@niftylettuce
Copy link

@niftylettuce niftylettuce commented Jul 26, 2016

You can use this if you need to in the meanwhile:

https://heroku.com/deploy?template=https://github.com/niftylettuce/slackin/tree/master

@zenspider
Copy link

@zenspider zenspider commented Aug 10, 2016

Confirmed that @niftylettuce's branch works fine. This bug has caused a LOT of teeth gnashing. Thank you @niftylettuce for the help!

@duaneking
Copy link

@duaneking duaneking commented Aug 13, 2016

When will this be fixed in the official branch?

@productcampsg
Copy link

@productcampsg productcampsg commented Aug 16, 2016

Thank you @niftylettuce! I had the Application Error page whenever I tried deploying to Heroku using the official branch.

I'm getting a 404 on http://slack.productcampsg.com/ but http://productcampsg.herokuapp.com shows the app.

Something like http://slack.mindtheproduct.com/ works. Does the Landing Page work for all of you 👀?

@niftylettuce
Copy link

@niftylettuce niftylettuce commented Sep 16, 2016

@productcampsg it works for me - maybe your Heroku dyno needs to be upgraded to Hobby or have a server ping it occasionally to wake up

@aaalveee
Copy link

@aaalveee aaalveee commented Dec 7, 2016

@niftylettuce's branch is crashing for me, shows "Application Error"

@rauchg rauchg closed this in 77c9d94 Feb 9, 2017
mexisme added a commit to devopsnz/slackin that referenced this issue Mar 10, 2017
mexisme added a commit to devopsnz/slackin that referenced this issue Mar 10, 2017
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
None yet
Linked pull requests

Successfully merging a pull request may close this issue.

None yet
8 participants
@zenspider @niftylettuce @duaneking @dgollahon @aaalveee @tonyedwardspz @productcampsg and others
You can’t perform that action at this time.