Skip to content
This repository

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP
branch: master
Fetching contributors…

Octocat-spinner-32-eaf2f5

Cannot retrieve contributors at this time

file 87 lines (72 sloc) 4.459 kb
1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86
= Samstag (2013-04-04) =
* Pinpad-Controller antwortete nicht mehr auf Ping
* Powercyclen vom Controller brachte nix
* Nach Busmasterreset gings wieder

= Dienstag/Mittwoch (2011-02-08) =
* Busmaster-Update (keine Link-Local-Adressen, sondern ULAs)
* RS485-Kabel gelegt (Kabel zur Tür wiederverwendet), durchgemessen, angeschlossen
* Neue Sensoren in der Tür an den Pinpad-Controller angeschlossen
* Firmware auf dem Pinpad-Controller Hausbus-fähig gemacht
* Pinpad-Events programmiert (Tastendruck, Öffnen, etc.)
* Türstatus-Script aktualisiert
* Video gemacht: Öffnen/Schließen via SSH
* Temperatur-Sensor-Platine gebaut

Hausbus lief ca. 2 Tage, dann unerklärliche Fehler (Pakete kamen nicht mehr ordentlich an)

= Dienstag/Mittwoch (2011-02-15) =
* Kabel zur Tür ordentlich abisoliert/verlötet (vorher Jumper Wires, die dann gebrochen sind)
* Debugging Session: Terminierung des Bus mit Widerständen zwischen A/B/VCC/GND fehlte, danach keine Errors mehr auf UART-Level
* Neue Pinpad-Frontend-Platine gelötet
* Ziffernfeld aus altem Telefon reverse-engineered
* LCD/LEDs/Ziffernfeld angesteuert von neuem Frontend aus
* Layout/Schaltplan gemacht (wir wollen eine Platine)

Hausbus lief wenige Stunden, dann stieg vermutlich wieder das Etherrape aus. Symptom bekannt, genaue Ursache noch unklar. Immerhin kein Fehler auf dem Bus selbst (vermutlich).

= Donnerstag (2011-02-17) =
* Pinpadv2-Platine layouten/fräsen mit Volker
* Pinpadv2-Platine bestückt

= Freitag/Samstag (2011-02-18) =
* RS485-auf-RS232-Platine ordentliche gelötet (Gegentaktdrossel, Ethernet, ggf. Bustreiber)
* Festgestellt, dass die Firebox crashed, wenn man mit der seriellen Schnittstelle dort Mist baut, ergo werden wir diese nicht als Busmaster verwenden
* Pinpad2-Platine gefixed (bei einem Kondensator war auf der Oberseite kein Lötzinn)
* HomeTec++: Bau einer Platine zur direkten Ansteuerung des HomeTecs (ohne dessen Elektronik). Serielle Schnittstelle der Platine funktioniert nicht, wenn die Platine über das Kabel, das bisher das Hometech mit Strom versorgt, versorgt wird. Sonst schon.
* Busmaster-Firmware auf das andere Etherrape aufgespielt (mit anderem Netzteil), eine kleine Verbesserung (unklar obs hilft) in der Firmware

Laufzeiten des Busmasters:
* 2011-02-19 11:06:00 bis 2011-02-19 18:27:00 (~ 7:30h)
* 2011-02-19 18:27:00 bis 2011-02-20 02:55:00 (~ 8:30h)
* 2011-02-20 02:56:00 bis 2011-02-20 09:54:00 (~ 7:00h)
* 2011-02-20 09:55:00 bis 2011-02-20 16:07:00 ← '''firmware-upgrade''', beabsichtigt
* 2011-02-20 16:08:00 bis 2011-02-20 19:25:00 (~ 3:00h)
* 2011-02-20 19:26:00 bis 2011-02-20 20:20:00 (~ 1:00h)
** Interessant: die 'handling udp packet'-meldung kam noch, die 'ethernet to rs485 done' nicht
* 2011-02-20 20:20:00 bis 2011-02-20 21:08:00 (~ 1:00h)
* 2011-02-20 21:34:00 bis 2011-02-20 21:55:00 (~ 1:30h)
* 2011-02-20 21:55:00 bis 2011-02-20 22:59:00 (~ 1:00h)
* 2011-02-20 23:00:00 bis 2011-02-21 02:22:00 (~ 3:30h)
* 2011-02-21 02:23:00 bis 2011-02-21 08:05:00 (~ 6:00h)
* 2011-02-21 08:06:00 bis 2011-02-21 12:50:00 (~ 5:00h)
* 2011-02-21 12:51:00 bis 2011-02-21 16:49:00 (~ 4:00h)
* 2011-02-21 16:50:00 bis 2011-02-21 20:10:00 (~ 3:00h)
* 2011-02-21 20:11:00 bis 2011-02-21 22:38:00 (~ 2:30h)

= Dienstag/Mittwoch (2011-02-22) =
* HomeTec++ gefixed, mit PWM ausgestattet zur Kommunikation
* Schließ-/Öffnungsvorgang ausprogrammiert
* HomeTec++ montiert und in Betrieb genommen
* Busmaster durch eine Resetcard ersetzt, hat allerdings keine Besserung gebracht. Liegt vmtl an fehlenden Kondensatoren rund um den ENC28J60 oder so.

= Freitag (2011-02-25) =
* Testaufbau für das UART-2-Ethernet-Modul gebaut, funktioniert leider noch nicht vollständig.
* HomeTec++ besser montiert/Kabel getauscht
* Temperatursensor-Platine weiterentwickelt

= Freitag (2011-03-04) =
* kleine Änderungen an der alten Busmaster-Firmware, keine Besserung erzielt
* nema10 + resetcard als Busmaster deployed

Laufzeiten alter Busmaster (Etherrape):
* 2011-03-04 20:45:00 bis 2011-03-05 02:00:00

Laufzeiten neuer Busmaster (Resetcard + serial2ethernet):
* 2011-03-05 06:17:00 bis …

= Dienstag (2011-03-08) =
* Benutzer-eigene Pins in Testbetrieb genommen, Busmaster scheint stabil
* Türstatus-API auf push umgestellt statt poll

= Dienstag (2011-03-15) =
Plan:
* FritzBox an Port 3 klemmen an der Firebox, Switch wieder abschalten bei geschlossenem Raum
* Temperatursensor-Platine an den Hausbus anschließen
* Pinpadv2-Frontend weitermachen
Something went wrong with that request. Please try again.