Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP
Browse files

improving documentation

  • Loading branch information...
commit 2f5545d2df9ec374f61c0830f1adf2d71d683b62 1 parent 8990b22
Raymond Gao authored
2  .gitignore
View
@@ -16,7 +16,9 @@ tmtags
## PROJECT::GENERAL
coverage
rdoc
+doc
pkg
+.yardoc
## PROJECT::SPECIFIC
nbproject/*
7 README.rdoc
View
@@ -114,15 +114,12 @@ lib
-- active_record -> asf model
-- salesforce -> convenience classes and utilities
-script
- Helper scripts for automation and generation.
-
test
- Unit and functional tests along with fixtures.
+ Unit and functional tests along with fixtures. See enclosed test app (asf-soap-adapter-rails-app) for full-fledge tests.
== Additional Note:
The enclosed test app (asf-soap-adapter-rails-app) shows how to use the framework. Go into its "test/unit" directory, where examples are provided.
-I am currently, updating my reference app SFRWatcher to SFRWatcher_v20 to match the switch from the old gem to this new gem. Once it is ready, it will be posted on the web soon.
+I am currently, updating my reference app SFRWatcher to SFRWatcher_v20 to match the switch from the old gem to this new gem. Once it is ready, it will be posted on the web soon. The project home: http://asf-soap-adapter.are4.us
Copyright (c) 2010 Raymond Gao. See LICENSE for details.
8 asf-soap-adapter.gemspec
View
@@ -5,7 +5,7 @@
Gem::Specification.new do |s|
s.name = %q{asf-soap-adapter}
- s.version = "0.9.15"
+ s.version = "0.9.16"
s.required_rubygems_version = Gem::Requirement.new(">= 0") if s.respond_to? :required_rubygems_version=
s.authors = ["Doug Chasman", "Luigi Montanez", "Senthil Nayagam", "Justin Ball", "Jesse Hallett", "Andrew Freeberg", "Blaine Schanfeldt", "Matte Edens", "Raymond Gao"]
@@ -279,16 +279,16 @@ Gem::Specification.new do |s|
s.specification_version = 3
if Gem::Version.new(Gem::VERSION) >= Gem::Version.new('1.2.0') then
- s.add_runtime_dependency(%q<rforce>, [">= 0.4.0"])
+ s.add_runtime_dependency(%q<rforce>, [">= 0.4.1"])
s.add_runtime_dependency(%q<builder>, [">= 1.2.4"])
s.add_runtime_dependency(%q<hpricot>, [">= 0.8.2"])
else
- s.add_dependency(%q<rforce>, [">= 0.4.0"])
+ s.add_dependency(%q<rforce>, [">= 0.4.1"])
s.add_dependency(%q<builder>, [">= 1.2.4"])
s.add_dependency(%q<hpricot>, [">= 0.8.2"])
end
else
- s.add_dependency(%q<rforce>, [">= 0.4.0"])
+ s.add_dependency(%q<rforce>, [">= 0.4.1"])
s.add_dependency(%q<builder>, [">= 1.2.4"])
s.add_dependency(%q<hpricot>, [">= 0.8.2"])
end
8 lib/salesforce/sf_utility.rb
View
@@ -88,7 +88,7 @@ def self.determine_sf_object_type(id)
# Finders the appropriate Salesforce Object based on Object. No more guess work.
- # nil means that the {oid} is not supported by this method, e.g. not suitable.
+ # <em>nil</em> means that the <em>oid</em> is not supported by this method, e.g. not suitable.
def self.salesforce_object_find_by_id (oid)
query_conditions = Hash.new
query_conditions[:id] = oid
@@ -104,7 +104,7 @@ def self.salesforce_object_find_by_id (oid)
end
# Finders the appropriate Salesforce Object based on Object Type and description
- # nil means that the {oid} is not supported by this method, e.g. not suitable.
+ # <em>nil</em> means that the <em>oid</em> is not supported by this method, e.g. not suitable.
def self.salesforce_object_find_by_type_and_conditions (otype, query_conditions)
# for example
#Salesforce::Group.find(:all, :conditions => ["email like :search", {:search => '%.com'}])
@@ -114,7 +114,7 @@ def self.salesforce_object_find_by_type_and_conditions (otype, query_conditions)
end
# Finders the appropriate Salesforce Object based on the Object Type
- # returning nil means that the {oid} is not supported by this method, e.g. not suitable.
+ # returning <em>nil</em> means that the <em>oid</em> is not supported by this method, e.g. not suitable.
def self.salesforce_object_find_all(otype, query_conditions = nil)
case otype
when 'Account'
@@ -211,4 +211,4 @@ def self.salesforce_object_create(otype)
end
-end
+end
Please sign in to comment.
Something went wrong with that request. Please try again.