PHP client library for communicating with GetEventStore.
Switch branches/tags
Clone or download
Fetching latest commit…
Cannot retrieve the latest commit at this time.
Permalink
Type Name Latest commit message Commit time
Failed to load latest commit information.
bin
src
tests
.gitignore
.php_cs
.travis.yml
LICENSE.md
README.md
composer.json
phpunit.xml

README.md

Build Status License Dependencies Code Quality

PHP GetEventStore client

This is a PHP client library for communicating with GetEventStore.

For now the it as been tested against V3.4.0 API, it has yet to be tested against other versions.

Requirements

Your PHP version should be at least 7.0.0., I think this shouldn't be a problem.

Event Sourcing generally has to be considered from the start of your project.

And as you are starting a new project, why not start it in PHP 7?

Installation

$ composer require rayrutjes/php-geteventstore-client

For now there only is an http client. You need to append Guzzle to your project.

$ composer require guzzlehttp/guzzle

Testing

$ composer update
$ vendor/bin/phpunit

Tests will be looking for an environment variable GES_BASE_URI. If none is found, it will use the default http://127.0.0.1:2113 uri for communication with the event store.

Some opinionated choices

  • We never use xml as a content type for http messages as it makes bodies grow in size.
  • For now, we use embed bodies in feeds to lower the number of http requests.

Contributing

Please feel free to contribute by any means.