Permalink
Browse files

Merge remote-tracking branch 'origin/master'

Conflicts:
	.gitignore
  • Loading branch information...
2 parents 75f9e1c + 00128ff commit dc0466ea3d26d4a405f507533c879987ee22c797 @raystorm committed Mar 7, 2014
View
@@ -5,3 +5,5 @@ tmp/
.settings
.buildpath
.parameters.yml
+framework-standard-edition/web/css/
+framework-standard-edition/web/js/
@@ -15,6 +15,7 @@ public function registerBundles()
new Symfony\Bundle\SwiftmailerBundle\SwiftmailerBundle(),
new Symfony\Bundle\AsseticBundle\AsseticBundle(),
new Doctrine\Bundle\DoctrineBundle\DoctrineBundle(),
+ new Doctrine\Bundle\MongoDBBundle\DoctrineMongoDBBundle(),
new Sensio\Bundle\FrameworkExtraBundle\SensioFrameworkExtraBundle(),
//Braincrafted Twitter Bootstrap Bundle
new Bc\Bundle\BootstrapBundle\BcBootstrapBundle(),
@@ -1,6 +1,7 @@
<?php
use Doctrine\Common\Annotations\AnnotationRegistry;
+use Doctrine\ODM\MongoDB\Mapping\Driver\AnnotationDriver;
use Composer\Autoload\ClassLoader;
/**
@@ -9,5 +10,6 @@
$loader = require __DIR__.'/../vendor/autoload.php';
AnnotationRegistry::registerLoader(array($loader, 'loadClass'));
+AnnotationDriver::registerAnnotationClasses();
return $loader;
@@ -2230,11 +2230,11 @@ protected $booted = false;
protected $name;
protected $startTime;
protected $loadClassCache;
-const VERSION ='2.4.1';
-const VERSION_ID ='20401';
+const VERSION ='2.4.2';
+const VERSION_ID ='20402';
const MAJOR_VERSION ='2';
const MINOR_VERSION ='4';
-const RELEASE_VERSION ='1';
+const RELEASE_VERSION ='2';
const EXTRA_VERSION ='';
public function __construct($environment, $debug)
{
@@ -103,6 +103,17 @@ doctrine:
orm:
auto_generate_proxy_classes: %kernel.debug%
auto_mapping: true
+
+#TODO: update this for whatever Cloudbees uses
+doctrine_mongodb:
+ connections:
+ default:
+ server: mongodb://localhost:27017
+ options: {}
+ default_database: test_database
+ document_managers:
+ default:
+ auto_mapping: true
# Swiftmailer Configuration
swiftmailer:
@@ -10,6 +10,8 @@
"symfony/symfony" : "~2.4",
"doctrine/orm" : "~2.2,>=2.2.3",
"doctrine/doctrine-bundle" : "~1.2",
+ "doctrine/mongodb-odm" : "1.0.*@dev",
+ "doctrine/mongodb-odm-bundle" : "3.0.*@dev",
"twig/extensions" : "~1.0",
"symfony/assetic-bundle" : "~2.3",
"symfony/swiftmailer-bundle" : "~2.3",
Oops, something went wrong.

0 comments on commit dc0466e

Please sign in to comment.