Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

^ support isn't npm-compatible #35

Closed
autopulated opened this issue Feb 18, 2016 · 1 comment

Comments

@autopulated
Copy link

commented Feb 18, 2016

npm treats ^ differently for 0.x versions, see the node-semver docs: https://github.com/npm/node-semver#caret-ranges-123-025-004

(and fwiw yotta also treats it differently, treating ^ for 0.x versions as meaning exact version, as semver technically has no compatibility guarantees for 0.x versions)

(While I was checking the code i also noticed a double-return here: https://github.com/rbarrois/python-semanticversion/blob/master/semantic_version/base.py#L462-L463)

@rbarrois rbarrois closed this in d10ab4c Feb 21, 2016

@autopulated

This comment has been minimized.

Copy link
Author

commented Feb 22, 2016

Thanks!

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
None yet
1 participant
You can’t perform that action at this time.