Permalink
Browse files

Added a ruby min version

  • Loading branch information...
1 parent 854b625 commit 6e2f5ed4dee068661772b8d5908bd8978b3431ac @rbgrouleff committed Sep 27, 2012
Showing with 13 additions and 11 deletions.
  1. +13 −11 wheelbarrow.gemspec
View
24 wheelbarrow.gemspec
@@ -4,16 +4,18 @@ $LOAD_PATH.unshift(lib) unless $LOAD_PATH.include?(lib)
require 'wheelbarrow/version'
Gem::Specification.new do |gem|
- gem.name = "Wheelbarrow"
- gem.version = Wheelbarrow::VERSION
- gem.authors = ["Rasmus Bang Grouleff"]
- gem.email = ["rasmus@nerdd.dk"]
- gem.description = %q{Automatic deployment of Ruby on Rails apps when pushing to a Git repo}
- gem.summary = %q{Automating the deployment procedure of Ruby on Rails apps - just push the app to a Git repo, and Wheelbarrow takes care of the rest.}
- gem.homepage = "https://github.com/rbgrouleff/wheelbarrow"
+ gem.name = "Wheelbarrow"
+ gem.version = Wheelbarrow::VERSION
+ gem.authors = ["Rasmus Bang Grouleff"]
+ gem.email = ["rasmus@nerdd.dk"]
+ gem.description = %q{Automatic deployment of Ruby on Rails apps when pushing to a Git repo}
+ gem.summary = %q{Automating the deployment procedure of Ruby on Rails apps - just push the app to a Git repo, and Wheelbarrow takes care of the rest.}
+ gem.homepage = "https://github.com/rbgrouleff/wheelbarrow"
- gem.files = `git ls-files`.split($/)
- gem.executables = gem.files.grep(%r{^bin/}).map{ |f| File.basename(f) }
- gem.test_files = gem.files.grep(%r{^(test|spec|features)/})
- gem.require_paths = ["lib"]
+ gem.required_ruby_version = '>= 1.9.3'
+
+ gem.files = `git ls-files`.split($/)
+ gem.executables = gem.files.grep(%r{^bin/}).map{ |f| File.basename(f) }
+ gem.test_files = gem.files.grep(%r{^(test|spec|features)/})
+ gem.require_paths = ["lib"]
end

0 comments on commit 6e2f5ed

Please sign in to comment.