Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with
or
.
Download ZIP
Mydeco fork of the xappy project : http://code.google.com/p/xappy/
Branch: master

This branch is 4 commits behind mydeco-dev-team:master

Fetching latest commit…

Cannot retrieve the latest commit at this time

Failed to load latest commit information.
docs
examples
external_posting_source
libs
perftest
research
testdata
utils
xappy
AUTHORS
COPYING_GPL
ChangeLog
MANIFEST.in
README
build.py
coverage.py
eggsetup.py
setup.py
test.py

README

README
======

Xappy provides a simple-to-use interface to a search engine (Xapian -
http://xapian.org/).

For an introduction to the "xappy" module, read the documentation in
"docs/introduction.html".  (If you have an SVN checkout, you may need to
generate this documentation by running "./build.py")

You can run the testsuite by running "./testsuite/runtests.py".

All changes are logged in the ChangeLog.

Prerequisites
-------------

- Python.  Version 2.4 or 2.5 should be suitable.  Earlier versions may not
  work correctly, and versions earlier than 2.2 will certainly not work
  (since they are not supported by Xapian).

- Xapian (core library and python bindings).  Currently, no release
  contains all the features needed for Xappy: you will need a snapshot
  release of Xapian.  Appropriate snapshots are available from the tarballs
  in the libs/ subdirectory: we do not currently support use of a version
  of Xapian other than that in those tarballs.

- rst2html and epydoc.  These are used to format the documentation - you
  should be able to use the "xappy" module without them, but it won't be
  so easy to know _how_ to use it!

- Python docutils.  This is needed for generating the documentation - most
  Python installations will already have docutils included, but you may
  need to install it specifically in some cases.

- If you want to use the colour similarity code, you will also need:

  - The python colormath library.  Get this from "easy_install colormath",
    or download a tarball from http://pypi.python.org/pypi/colormath/
  - Scipy version 0.7 or later, for the image facet clustering code.

Building
--------

The xappy module is pure Python, and thus doesn't really need to be built.
However, there is a "build.py" script at the top level of the project -
this will generate all the documentation.
Something went wrong with that request. Please try again.