Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with
or
.
Download ZIP
Browse files

Added setup, added first pass at readme.

  • Loading branch information...
commit 429a9432d62bdd6f690cb8b4ca327db322d803e4 1 parent dd27619
@rbrady authored
Showing with 71 additions and 0 deletions.
  1. +39 −0 README.rst
  2. +32 −0 setup.py
View
39 README.rst
@@ -0,0 +1,39 @@
+====================
+Django Bootstrapped
+====================
+
+Bootstrapped is a reusable Django application to quickly integrate the Bootstrap toolkit from Twitter. It's a
+collection of the bootstrap toolkit files and template tags to display them.
+
+This application depends on django.contrib.staticfiles.
+
+No files from Twitter's Bootstrap toolkit have been modified and retain their Apache 2.0 license.
+
+* Note: This app only works on Django 1.3 and newer.
+
+Installation
+============
+
+pip install django-bootstrapped
+
+
+Configuration
+=============
+
+#. Add the `bootstrapped` directory to your Python path.
+
+#. Ensure `django.contrib.staticfiles` is added to your `INSTALLED_APPS` setting.
+
+#. Ensure `django.contrib.staticfiles` is configured properly.
+
+#. Add `bootstrapped` to your `INSTALLED_APPS` setting.
+
+#. Run `manage.py collectstatic` to copy the Twitter Bootstrap toolkit files to your static directory.
+
+
+Template Usage
+=================
+
+TODO: Explain each template tag and all permutations.
+
+TODO: Explain how to customize/override using less.
View
32 setup.py
@@ -0,0 +1,32 @@
+from setuptools import setup, find_packages
+
+setup(
+ name='django-bootstrapped',
+ version='0.1.0-dev',
+ description='A reusable Django application to quickly integrate the Bootstrap toolkit from Twitter.',
+ long_description=open('README.rst').read(),
+ # Get more strings from http://www.python.org/pypi?:action=list_classifiers
+ author='Ryan Brady',
+ author_email='ryan@ryanbrady.org',
+ url='https://github.com/rbrady/django-bootstrapped',
+ download_url='https://github.com/rbrady/django-bootstrapped/downloads',
+ license='BSD',
+ packages=find_packages(exclude=('ez_setup', 'tests', 'example')),
+ # tests are on the roadmap
+ #tests_require=[
+ # 'django>=1.3,<1.4',
+ #],
+ #test_suite='runtests.runtests',
+ include_package_data=True,
+ zip_safe=False, # because we're including media that Django needs
+ classifiers=[
+ 'Development Status :: 4 - Beta',
+ 'Environment :: Web Environment',
+ 'Framework :: Django',
+ 'Intended Audience :: Developers',
+ 'License :: OSI Approved :: BSD License',
+ 'Operating System :: OS Independent',
+ 'Programming Language :: Python',
+ 'Topic :: Software Development :: Libraries :: Python Modules',
+ ],
+)
Please sign in to comment.
Something went wrong with that request. Please try again.