Skip to content
jump to the Vim script's last error
Vim script
Branch: master
Clone or download
Fetching latest commit…
Cannot retrieve the latest commit at this time.
Permalink
Type Name Latest commit message Commit time
Failed to load latest commit information.
autoload
doc
plugin
.travis.yml
LICENSE
README.md
vimscript_lasterror.gif

README.md

vim-vimscript_lasterror Build Status

This plugin provides to jump to the Vim script's last error.

Usage

:VimscriptLastError [-loclist] [-quickfix]

If -loclist and -quickfix are not specified, jump to the Vim script's last error.
If -loclist is specified, set Vim script's errors to current loclist.
If -quickfix is specified, set Vim script's errors to quickfix.

Remarks

  • This plugin find Vim script's errors from output of :messages.
  • This plugin does not support a lambda function's error such as VimscriptLasterrorComp[1]..<lambda>59.

Concepts

  • This plugin supports Vim and Neovim.
  • This plugin does not provide to customize user-settings.
  • This plugin provides only one command.

Inspired by

License

Distributed under MIT License. See LICENSE.

You can’t perform that action at this time.