Browse files

Add POE::Test::Loops to configure_requires and build_requires.

  • Loading branch information...
1 parent 751d3da commit e4a6793ce3c01ffa8127a6b824bc1b4449099485 @rcaputo committed Aug 26, 2009
Showing with 14 additions and 4 deletions.
  1. +11 −1 polo-tk/Makefile.PL
  2. +1 −1 polo-tk/lib/POE/Loop/Tk.pm
  3. +1 −1 polo-tk/lib/POE/Loop/TkActiveState.pm
  4. +1 −1 polo-tk/lib/POE/Loop/TkCommon.pm
View
12 polo-tk/Makefile.PL
@@ -88,7 +88,17 @@ WriteMakefile(
clean => { FILES => 't/poe_loop_tk/*.t t/poe_loop_tk' },
test => { TESTS => 't/poe_loop_tk/*.t' },
- # More for META.yml than anything.
+ CONFIGURE_REQUIRES => {
+ 'ExtUtils::MakeMaker' => 0,
+ 'POE::Test::Loops' => 1.021,
+ },
+
+ META_MERGE => {
+ build_requires => {
+ 'POE::Test::Loops' => 1.021,
+ },
+ },
+
PREREQ_PM => {
'POE' => 1.007,
'POE::Test::Loops' => 1.021,
View
2 polo-tk/lib/POE/Loop/Tk.pm
@@ -3,7 +3,7 @@
package POE::Loop::Tk;
use vars qw($VERSION);
-$VERSION = '1.300'; # NOTE - Should be #.### (three decimal places)
+$VERSION = '1.301'; # NOTE - Should be #.### (three decimal places)
# Include common things.
use POE::Loop::PerlSignals;
View
2 polo-tk/lib/POE/Loop/TkActiveState.pm
@@ -4,7 +4,7 @@
package POE::Loop::TkActiveState;
use vars qw($VERSION);
-$VERSION = '1.300'; # NOTE - Should be #.### (three decimal places)
+$VERSION = '1.301'; # NOTE - Should be #.### (three decimal places)
# Merge things into POE::Loop::Tk.
package POE::Loop::Tk;
View
2 polo-tk/lib/POE/Loop/TkCommon.pm
@@ -8,7 +8,7 @@ package POE::Loop::TkCommon;
use POE::Loop::PerlSignals;
use vars qw($VERSION);
-$VERSION = '1.300'; # NOTE - Should be #.### (three decimal places)
+$VERSION = '1.301'; # NOTE - Should be #.### (three decimal places)
use Tk 800.021;
use 5.00503;

0 comments on commit e4a6793

Please sign in to comment.