Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with
or
.
Download ZIP
Browse files

Fix post-install message and required ruby version

  • Loading branch information...
commit a7037ca3aad48714d1e471bf281450cd20c39996 1 parent 51755c8
@drbrain drbrain authored
Showing with 12 additions and 3 deletions.
  1. +2 −0  History.txt
  2. +10 −3 Rakefile
View
2  History.txt
@@ -12,6 +12,8 @@
* Darkfish now supports sections. Template and generator author see
RDoc::Context#each_section to add section support. RubyForge Bug #26883
by Jeff Hodges.
+ * Fixed post-install message for Ruby 1.9.2 users.
+ * Set required ruby version to >= 1.8.7.
=== 3.5.1 / 2010-01-30
View
13 Rakefile
@@ -16,11 +16,13 @@ Hoe.spec 'rdoc' do
developer 'Tony Strauss', 'tony.strauss@designingpatterns.com'
self.rsync_args = '-avz'
+ rdoc_locations << 'docs.seattlerb.org:/data/www/docs.seattlerb.org/rdoc/'
rdoc_locations << 'drbrain@rubyforge.org:/var/www/gforge-projects/rdoc/'
self.testlib = :minitest
self.isolate_dir = 'tmp/isolate'
+ require_ruby_version '>= 1.8.7'
extra_dev_deps << ['minitest', '~> 2']
extra_dev_deps << ['isolate', '~> 3']
extra_dev_deps << ['ZenTest', '~> 4'] # for autotest/isolate
@@ -30,10 +32,12 @@ Hoe.spec 'rdoc' do
spec_extras['homepage'] = 'http://rdoc.rubyforge.org'
spec_extras[:post_install_message] = <<-EOF
-RDoc 2.5 did not save method parameters, so you should upgrade your rdoc-data
-gem to a version >= 2.5.3.
+NOTE: If you are running Ruby 1.9.2 you can ignore this message.
-To have ri data for core and stdlib you'll need to:
+RDoc 2.5+ has a new ri data format for Ruby 1.8.7 and 1.9.1. (1.9.2 contains
+RDoc 2.5 so there is nothing to do!)
+
+To install new ri data for core and stdlib you'll need to:
gem install rdoc-data
@@ -46,6 +50,9 @@ To have ri data for you gems you'll also need to run:
gem rdoc --all --overwrite
If you don't want to rebuild the rdoc for `gem server`, add --no-rdoc.
+
+NOTE: RDoc 2.5 did not save method parameters, so you should upgrade your
+rdoc-data gem to a version >= 2.5.3 if you installed an older version.
EOF
end
Please sign in to comment.
Something went wrong with that request. Please try again.