Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with
or
.
Download ZIP
Branch: master
Commits on Apr 9, 2012
  1. better error message

    authored
Commits on Jan 8, 2012
  1. @luislavena

    Prepare for release

    luislavena authored
  2. @luislavena
  3. @luislavena
  4. @luislavena
  5. @luislavena

    Get rid of RCov

    luislavena authored
Commits on Nov 1, 2011
  1. @luislavena
  2. @luislavena

    Bump supported versions for testing

    luislavena authored
    Ruby 1.8.7 and Ruby 1.9.2 are the minimum cross-compiled versions
    supported.
  3. @luislavena

    Merge pull request #49 from larskanis/master

    luislavena authored
    Detect 32bit mingw-gcc executable for cross compile
  4. @luislavena

    Merge pull request #48 from mvz/silence-cross-configuration-warning

    luislavena authored
    Generate dummy cross-compile target when no configuration exists.
    
    Also closes #16
Commits on Oct 31, 2011
  1. @larskanis
Commits on Oct 30, 2011
  1. @mvz
Commits on Oct 5, 2011
  1. @luislavena
  2. @luislavena

    Merge pull request #45 from jfirebaugh/jruby_warning

    luislavena authored
    Only emit warnings when doing cross-compilation tasks
  3. @luislavena

    Add some test harness to latest changes

    luislavena authored
    And also update History to reflect the new change in codebase
  4. @luislavena

    Merge pull request #47 from jonforums/extconf-args-fix

    luislavena authored
    Pass extra Rake cmd line args to extconf.rb
  5. @jonforums

    Pass extra Rake cmd line args to extconf.rb

    jonforums authored
    Example usage:
    
      rake compile -- --with-libyaml-dir=C:/devlibs/libyaml
Commits on Aug 7, 2011
  1. @jfirebaugh
Commits on Jun 8, 2011
  1. @luislavena
  2. @luislavena

    Bump version

    luislavena authored
  3. @luislavena
  4. @luislavena
  5. @luislavena

    Workaround Gem::Specification limitation. Closes #43

    luislavena authored
    Since Rake::ExtensionTask reuses the gem specification, we fall into
    the memoization issue described in RubyGems bug:
    
    http://github.com/rubygems/rubygems/issues/78
    
    Applied a workaround until that issue is sorted out.
  6. @luislavena

    Use Gem::PackageTask instead of Rake one

    luislavena authored
    Rake::GemPackageTask is deprecated and will be removed.
    
    Gem::PackageTask has been present since RubyGems 1.3.2 and should be
    used instead.
    
    rake-compiler already depends on rubygems >= 1.3.5 so no damage done here.
  7. @luislavena
  8. @luislavena
  9. @luislavena

    Don't nuke tmp directory every time

    luislavena authored
    Isolate default installation is tmp... Now I remember.
  10. @luislavena
  11. @luislavena
Commits on May 5, 2011
  1. @luislavena
Commits on May 4, 2011
  1. @luislavena

    Merge pull request #39 from kou/master.

    luislavena authored
    fake.rb may use different RUBY_PLATFORM.
  2. @kou
Commits on Apr 26, 2011
  1. @luislavena

    Prepare for newer release

    luislavena authored
  2. @luislavena
  3. @luislavena
Something went wrong with that request. Please try again.