Browse files

Merge pull request #1 from carlosantoniodasilva/update-dependencies

Be less restrictive on actionpack dependency to allow any Rails 3.x version
  • Loading branch information...
2 parents 8968a34 + 57380b3 commit 2aeffa36579660613c04b106a5dce5d4d90163fb @rdy committed Mar 22, 2012
Showing with 3 additions and 2 deletions.
  1. +2 −1 lib/sprockets/jquery/tmpl/tmpl_processor.rb
  2. +1 −1 sprockets-jquery-tmpl.gemspec
View
3 lib/sprockets/jquery/tmpl/tmpl_processor.rb
@@ -1,3 +1,4 @@
+require 'sprockets'
require 'sprockets/engines'
require 'tilt'
require 'action_view'
@@ -27,6 +28,6 @@ def evaluate(scope, locals, &block)
end
end
end
-
+
register_engine '.tmpl', ::Sprockets::Jquery::Tmpl::TmplProcessor
end
View
2 sprockets-jquery-tmpl.gemspec
@@ -18,5 +18,5 @@ Gem::Specification.new do |s|
s.executables = `git ls-files -- bin/*`.split("\n").map{ |f| File.basename(f) }
s.require_paths = ["lib"]
- s.add_dependency 'actionpack', '~> 3.1.0'
+ s.add_dependency 'actionpack', '~> 3.1'
end

0 comments on commit 2aeffa3

Please sign in to comment.