Skip to content
Permalink
Browse files

cssloader: Rename "browsers" to "overrideBrowserslist" (#1251)

Running `react-static` currently prints this warning:

```
Replace Autoprefixer browsers option to Browserslist config.
Use browserslist key in package.json or .browserslistrc file.

Using browsers option cause some error. Browserslist config
can be used for Babel, Autoprefixer, postcss-normalize and other tools.

If you really need to use option, rename it to overrideBrowserslist.

Learn more at:
https://github.com/browserslist/browserslist#readme
https://twitter.com/browserslist
```

It goes away by renaming `browsers` to `overrideBrowserslist` as
suggested.

Signed-off-by: Juan Cruz Viotti <jv@jviotti.com>
  • Loading branch information...
jviotti authored and sw-yx committed Jul 3, 2019
1 parent 64bd362 commit c546443e46132a5ea67f0a8afe9e1d44fc1bb64b
Showing with 1 addition and 1 deletion.
  1. +1 −1 packages/react-static/src/static/webpack/rules/cssLoader.js
@@ -21,7 +21,7 @@ function initCSSLoader() {
plugins: () => [
postcssFlexbugsFixes,
autoprefixer({
browsers: [
overrideBrowserslist: [
'>1%',
'last 4 versions',
'Firefox ESR',

0 comments on commit c546443

Please sign in to comment.
You can’t perform that action at this time.