Skip to content
Permalink
Browse files

Add support for latest VS2017 (15.0) compiler (#1050)

Latest VS 2017 CL.EXE compiler (version 19.16...) wasn't being correctly detected by the configure.cmd script.
  • Loading branch information...
wjk authored and HBelusca committed Nov 19, 2018
1 parent 154ed37 commit f6f1255cf7b9166645092130576a40ee44932227
Showing with 1 addition and 0 deletions.
  1. +1 −0 configure.cmd
@@ -72,6 +72,7 @@ if defined ROS_ARCH (
cl 2>&1 | find "19.13." > NUL && set VS_VERSION=15
cl 2>&1 | find "19.14." > NUL && set VS_VERSION=15
cl 2>&1 | find "19.15." > NUL && set VS_VERSION=15
cl 2>&1 | find "19.16." > NUL && set VS_VERSION=15
if not defined VS_VERSION (
echo Error: Visual Studio version too old ^(before 10 ^(2010^)^) or version detection failed.
goto quit

1 comment on commit f6f1255

@binarymaster

This comment has been minimized.

Copy link
Contributor

commented on f6f1255 Nov 19, 2018

Add support for latest VS2017 (15.0) compiler

Just FYI: This commit actually adds support for Visual Studio 15.9 compiler, not 15.0, so there is a typo in commit message.

Please sign in to comment.
You can’t perform that action at this time.