Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Forward compatibility with upcoming Cache v0.6 and Cache v1.0 #121

Merged
merged 1 commit into from
Jan 30, 2019

Conversation

clue
Copy link
Member

@clue clue commented Jan 29, 2019

Cache v0.6 is going to be tagged soon: https://github.com/reactphp/cache/milestone/4. This component is already compatible with both the upcoming version as well as legacy versions. The Cache component is pretty much stable already and we plan to not introduce any BC breaks anymore: reactphp/cache#8

Builds on top of #102

@kelunik
Copy link

kelunik commented Jan 29, 2019

What's the reason to do these before the release? I may have already asked this, sorry if that's the case.

@clue
Copy link
Member Author

clue commented Jan 29, 2019

What's the reason to do these before the release?

Both approaches are workable. We want to ensure that people will be able to install the new cache component ASAP when the new release is out, hence we try to make components that depend on this version compatible before the release.

@kelunik
Copy link

kelunik commented Jan 30, 2019

@clue thanks!

@clue clue merged commit d0ef329 into reactphp:master Jan 30, 2019
@clue clue deleted the cache-compatibility branch January 30, 2019 09:15
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
None yet
Development

Successfully merging this pull request may close these issues.

None yet

4 participants