Update tests to support updated deps which use PSR-4 for tests #364

Merged
merged 2 commits into from Jan 9, 2017

Projects

None yet

3 participants

@clue
Member
clue commented Dec 27, 2016

The tests currently fail due to the updated Travis image setup which no longer supports testing IPv6 connections which the test suite previously relied on.

I've updated the test suite via reactphp/socket-client#76 and updated the dependency to socket-client: ^0.5.3 but this requires further updates to the test suite in order to now support PSR-4 for our test suites. I've updated the test/boostrap.php to account for the new autoload paths and manually added some require-dev statements, but I consider this a rather fragile for the future.

Anyway, this should fix this for the moment and we can clean this up (or re-consider the whole test suite) in the future 👍

@jsor
jsor approved these changes Jan 8, 2017 View changes
@clue clue merged commit 2925dd5 into reactphp:master Jan 9, 2017

1 check passed

continuous-integration/travis-ci/pr The Travis CI build passed
Details
@clue clue deleted the clue-labs:tests branch Jan 9, 2017
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment