Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

RTD building old "stable" docs instead of "latest" when auto-triggered from recent push #2351

Closed
chummels opened this issue Aug 4, 2016 · 3 comments

Comments

@chummels
Copy link

@chummels chummels commented Aug 4, 2016

Details

Expected Result

The "latest" docs to be built when triggered by updates to the BitBucket repository.

Actual Result

The "stable" branch of the docs are built when triggered by updates to the BitBucket repository.

Additional Information

I am not sure if it is related, but in the last few weeks, I have been experiencing some weird behavior with bitbucket's webhooks for automatically triggering RTD builds. When I push a change to the BitBucket repository, it triggers a webhook to be sent to: https://readthedocs.org/build/trident , but it times out. It subsequently auto-sends two more webhooks to RTD, each of them timing out too.

When I look at what builds are occurring on the RTD side of things, there are three separate builds that have been started by these webhooks, each for the "stable" (i.e. old) branch, not the "latest" tip. After they each build successfully, I receive an email from RTD informing me that my build failed (link to a "failing" build at: https://readthedocs.org/projects/trident/builds/4264796/ ). After that, I am able to manually trigger a build of the "latest" docs, so RTD knows about the new code, it's just not auto-building it. I'm not sure how to resolve this issue, but it appears to be a bug somewhere, either on RTD or on BitBucket. Any suggestions are welcome. Thank you!

@humitos
Copy link
Member

@humitos humitos commented Feb 26, 2017

Maybe it's related to #2563

Loading

@stsewd
Copy link
Member

@stsewd stsewd commented Jan 16, 2018

@chummels are you still having this issue? Your latest builds are building successfully. I also noted that you migrate the project to GitHub, was because of this issue?

Loading

@chummels
Copy link
Author

@chummels chummels commented Jan 16, 2018

We moved to github for a number of reasons, but these problems with rtd were not the main cause. That said, it appears that the issue is now resolved with the move to github.

Loading

@chummels chummels closed this Jan 16, 2018
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
None yet
Linked pull requests

Successfully merging a pull request may close this issue.

None yet
4 participants