Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Documentation stuck in 'cloning' state #2795

Closed
virtuald opened this issue Apr 14, 2017 · 8 comments
Closed

Documentation stuck in 'cloning' state #2795

virtuald opened this issue Apr 14, 2017 · 8 comments

Comments

@virtuald
Copy link
Contributor

@virtuald virtuald commented Apr 14, 2017

Details

Expected Result

Build to... build.

Actual Result

4 builds appear to be stuck in 'cloning' state.... which is strange, because a builds were working fine earlier.

@bwohlberg
Copy link

@bwohlberg bwohlberg commented Apr 14, 2017

I'm experiencing the same problem with the docs for project sporco. One of the builds has been stuck in 'cloning' state for 36 hours.

@dpdani
Copy link

@dpdani dpdani commented Apr 14, 2017

Same here with 5 builds in Cloning state. The oldest one being about 3 hours old.

  • #5290405
  • #5290768
  • #5290989
  • #5291057
  • #5291066

@virtuald
Copy link
Contributor Author

@virtuald virtuald commented Apr 16, 2017

New builds are working now, but old builds still stuck in 'cloning' state. Feel free to close.

@bwohlberg
Copy link

@bwohlberg bwohlberg commented Apr 16, 2017

Based on previous bug reports it looks as if this problem has occurred previously as well; it's probably worth trying to locate the cause rather than just closing the issue.

@humitos
Copy link
Member

@humitos humitos commented Apr 18, 2017

These kind of errors I think are because there was a problem in the git clone command, and exception was raised, the process ended and the status wasn't communicated, so it seems that it's still cloning.

Common errors are:

  • the repository is private and requires username/password to be cloned
  • temporary network error
  • wrong git url
  • error in .gitmodules files

I think that a good enhancement would be that instead of showing Cloning, RTD should show the error message returned by the git clone command. For example,

fatal: could not read Username for 'https://bitbucket.org': No such device or address

@agjohnson
Copy link
Contributor

@agjohnson agjohnson commented Apr 18, 2017

I agree, we need to be more defensive around the clone stage. We should also be assuming a build has failed after a certain threshold, builds shouldn't be sticking around as "cloning" or any other temporary state.

The first case is easier to catch -- perhaps just some generic exception or exit code handling is all that is needed. It would be best if we can ensure state here, and avoid having to alter this state afterwards.

@humitos
Copy link
Member

@humitos humitos commented Apr 18, 2017

Another issue that talks about the ability of killing this blocked in some status: #2471

@bcb
Copy link

@bcb bcb commented Jul 14, 2017

This is still a problem. Stuck at "cloning".

screen shot 2017-07-15 at 03 29 08

humitos added a commit that referenced this issue Nov 23, 2017
humitos added a commit that referenced this issue Dec 7, 2017
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
None yet
Linked pull requests

Successfully merging a pull request may close this issue.

None yet
6 participants