Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Don't install pygments #7490

Merged
merged 1 commit into from Sep 21, 2020
Merged

Don't install pygments #7490

merged 1 commit into from Sep 21, 2020

Conversation

stsewd
Copy link
Member

@stsewd stsewd commented Sep 17, 2020

@stsewd stsewd force-pushed the dont-install-pygments branch from 008b396 to 78c9843 Compare Sep 17, 2020
@stsewd stsewd requested a review from a team Sep 17, 2020
Copy link
Member

@humitos humitos left a comment

LGTM! However, this will affect all the builds so I think we should make this a feature flag so we can rollout this smoothly without breaking everything and being safe.

@eric-wieser
Copy link
Contributor

eric-wieser commented Sep 18, 2020

Note that many projects were recently broken by the absence of this change (#7492)

@stsewd
Copy link
Member Author

stsewd commented Sep 18, 2020

It's installed as a dependency of sphinx, not sure if we need a feature flag for this. Also, builds are broken bc of this.

@humitos
Copy link
Member

humitos commented Sep 21, 2020

@stsewd Do you know why pygments was originally pinned? You said that since Sphinx 1.0 it's a dependency declared. However, we pinned it while using 1.2.2 at 5c7c11f for some reason.

@stsewd
Copy link
Member Author

stsewd commented Sep 21, 2020

@ericholscher should have more context for that change

@ericholscher
Copy link
Member

ericholscher commented Sep 21, 2020

Not sure -- that was a long time ago. I think it should be fine to unpin.

Copy link
Member

@ericholscher ericholscher left a comment

Seems safe enough 👍

@stsewd stsewd merged commit 61bd725 into master Sep 21, 2020
2 checks passed
@stsewd stsewd deleted the dont-install-pygments branch Sep 21, 2020
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Labels
None yet
Projects
None yet
Development

Successfully merging this pull request may close these issues.

Outdated pygments version?
4 participants