New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

OSX Cycle Actions window not working #332

Closed
Jeff0S opened this Issue Jul 8, 2014 · 6 comments

Comments

Projects
None yet
1 participant
@Jeff0S
Member

Jeff0S commented Jul 8, 2014

From timlloyd...@gmail.com on August 05, 2011 11:58:15

What's the problem? ... Setting up cycle action:

There is no way to select an action apart from a right-click > "add command" and then typing in the ID of the action. Should there not also be an "add action" option in the right-click menu?

For example, typing in 41696 seems to work, and displays the name of the action correctly (Layout: apply custom layout #1).

However, after setting up the cycle action, clicking "Apply" or "OK" results in the following S&M warning window:

"Warning: cycle action ''"Cycle default-test layout for mcp' (section 'Main') was added but not registered Details: command id (or custom id) '' not found"

Clicking "Apply" sometimes adds "" to the beginning of the cycling action name, and sometimes adds a ' "command" to the end of the action. How do you reproduce it? ... See above. What Reaper version, SWS verison, and OS version are you running? ... Reaper v4.01, SWS 2.0.0.34 BETA, OSX 10.6.8

Original issue: http://code.google.com/p/sws-extension/issues/detail?id=332

@Jeff0S

This comment has been minimized.

Member

Jeff0S commented Jul 8, 2014

From jeffos...@gmail.com on August 05, 2011 03:23:12

Thank you for the detailed report Tim! Yes, that's clearly an OSX bug. Sorry for the trouble..

@tim (SWS)
Aww.. This is so frustrating! I wish I had a Mac..
Rather than bugging you once again + even if fixed, I dare we'll then find other issues (again) so I could probably fix everything once for all with what we discussed in private - at least we could use that for a stable v2.0 and look to it again later (?)
Let me know what you think.

Labels: -Type-Beta Type-Defect Priority-Medium OpSys-OSX

@Jeff0S

This comment has been minimized.

Member

Jeff0S commented Jul 8, 2014

From jeffos...@gmail.com on August 05, 2011 03:24:12

Owner: jeffos...@gmail.com

@Jeff0S

This comment has been minimized.

Member

Jeff0S commented Jul 8, 2014

From timlloyd...@gmail.com on August 06, 2011 08:29:54

I'm happy to test builds for you if that's helpful?

@Jeff0S

This comment has been minimized.

Member

Jeff0S commented Jul 8, 2014

From jeffos...@gmail.com on August 08, 2011 02:22:20

This issue was closed by revision r527 .

Status: Fixed

@Jeff0S

This comment has been minimized.

Member

Jeff0S commented Jul 8, 2014

From jeffos...@gmail.com on August 08, 2011 02:27:24

^^ the previous message was autotmatic..

Yes Tim, that would be helpfull. Thanks!

What would be great is to do a basic test on OSX with the next build (create a cycle action from A to Z and perform it too) before annoucing the new release on the forums.
Unfortunately I can't build .dmg files, we'll have to wait for Tim (SWS)

@Jeff0S

This comment has been minimized.

Member

Jeff0S commented Jul 8, 2014

From jeffos...@gmail.com on August 08, 2011 02:29:15

Tim, I forgot! The "fix" is radical. To create a cycle action on OSX, it will work this way now (from the whatsnew):
On OSX: replaced the cycle action editor with a basic "create cycle action"
modal dialog box. This dialog box can be opened from the actions list (there are
3 "create cycle action" actions) but not from the main "Extensions" menu like on
Windows.

@Jeff0S Jeff0S closed this Jul 8, 2014

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment