Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

crash on project load #358

Closed
Jeff0S opened this Issue Jul 8, 2014 · 3 comments

Comments

Projects
None yet
1 participant
@Jeff0S
Copy link
Member

Jeff0S commented Jul 8, 2014

From jeffos...@gmail.com on August 24, 2011 19:50:30

http://forum.cockos.com/showthread.php?t=86567 Confirmed (SVN HEAD). I got that in the call stack but couldn't locate the issue exactlty

reaper_sws.dll!_VEC_memzero(void * dst=0x0012525c, int val=1191696, int len=18) + 0x82 bytes C

Original issue: http://code.google.com/p/sws-extension/issues/detail?id=358

@Jeff0S

This comment has been minimized.

Copy link
Member Author

Jeff0S commented Jul 8, 2014

From swstim on August 24, 2011 11:44:38

I can repro too. It's a tricky one...

Status: Investigating

@Jeff0S

This comment has been minimized.

Copy link
Member Author

Jeff0S commented Jul 8, 2014

From swstim on August 24, 2011 14:28:36

Jeffos, looks like it's caused by the % in the project notes string.

Details:

Break @ SnM_NotesHelpView.cpp:1100, and then dig into SnM_Misc.cpp:219, which is a call to ctx->AddLine() that contains the string with "% S". Since AddLine is your standard printf-style variable argument function it looks for more arguments and crashes.

You'll have to sanitize the project notes a little harder! :)

@Jeff0S

This comment has been minimized.

Copy link
Member Author

Jeff0S commented Jul 8, 2014

From jeffos...@gmail.com on August 24, 2011 16:48:09

"% S" from hell!

fixed in r541

Status: Fixed
Owner: jeffos...@gmail.com

@Jeff0S Jeff0S closed this Jul 8, 2014

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
You can’t perform that action at this time.