New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Snapshot paste - track destination for not-avaliable tracks #577

Closed
Jeff0S opened this Issue Jul 8, 2014 · 6 comments

Comments

Projects
None yet
1 participant
@Jeff0S
Member

Jeff0S commented Jul 8, 2014

From kusiho...@gmx.de on May 22, 2013 21:24:50

What steps will reproduce the problem? See attached pitcures.
Say I have two sessions, RPP1 and RPP2.
Track layout is pretty similar, but RPP1 has two tracks more (TOM1 and TOM2 in this example)
Now I want to copy / paste the settings of all the drum tracks from RPP1 into RPP2. I select ALL drumtracks in RPP1, including the TOM-tracks (explanation see below). What is the expected output? What do you see instead? Problem: the destination of the TOM tracks from the source tracks is not correct! It should be (none), since they don’t exist in RPP2.

I know, the easiest way would be not to select/copy the tracks that are not available in both sessions. Or change their destination manually.
But in big sessions (+50 tracks) with slightly different layouts, this can become really confusing.
(the project in the pictures is a small one to simplify the problem ;))

What version of SWS extension are you using? (Extensions -> About SWS...)
2.3.0 What is your Reaper version number and CPU architecture (e.g. Reaper 3.75 x64)? v4.402 32-bit What operating system are you running? (e.g. Windows XP/7, OSX 10.5.8 etc, 64bit?) WIN 7 32 bit

THANKS FOR YOUR SUPPORT!! :) :) SWS-EXTENSIONS ROCKS!! :)

Attachment: RPP1.png RPP2.png paste.png RPP1.RPP RPP2.RPP

Original issue: http://code.google.com/p/sws-extension/issues/detail?id=577

@Jeff0S

This comment has been minimized.

Show comment
Hide comment
@Jeff0S

Jeff0S Jul 8, 2014

Member

From swstim on May 22, 2013 22:15:09

Wow, this is an awesome bug report, thank you for the attachments. I will certainly give this a look as soon as I have a chance.

On another note, you are using this feature exactly as I intended. This makes me happy. :) I know it's complicated, but sometimes it's just the ticket.

Status: Investigating
Owner: swstim

Member

Jeff0S commented Jul 8, 2014

From swstim on May 22, 2013 22:15:09

Wow, this is an awesome bug report, thank you for the attachments. I will certainly give this a look as soon as I have a chance.

On another note, you are using this feature exactly as I intended. This makes me happy. :) I know it's complicated, but sometimes it's just the ticket.

Status: Investigating
Owner: swstim

@Jeff0S

This comment has been minimized.

Show comment
Hide comment
@Jeff0S

Jeff0S Jul 8, 2014

Member

From kusiho...@gmx.de on May 22, 2013 22:35:43

hi SWS-tim,

thanks for your support! :) just let me know if you need any fruther informations / investigation or testing, ok?

i dont think this snapshot-feature is complicated! it took some experiments/testing until i've got used to it, but now it feels all naturally. ;)

best greetings from switzerland!
markus

Member

Jeff0S commented Jul 8, 2014

From kusiho...@gmx.de on May 22, 2013 22:35:43

hi SWS-tim,

thanks for your support! :) just let me know if you need any fruther informations / investigation or testing, ok?

i dont think this snapshot-feature is complicated! it took some experiments/testing until i've got used to it, but now it feels all naturally. ;)

best greetings from switzerland!
markus

@Jeff0S

This comment has been minimized.

Show comment
Hide comment
@Jeff0S

Jeff0S Jul 8, 2014

Member

From markus.h...@gmail.com on July 04, 2013 02:11:39

hi tim,

any news on this one?

thanks!
markus

Member

Jeff0S commented Jul 8, 2014

From markus.h...@gmail.com on July 04, 2013 02:11:39

hi tim,

any news on this one?

thanks!
markus

@Jeff0S

This comment has been minimized.

Show comment
Hide comment
@Jeff0S

Jeff0S Jul 8, 2014

Member

From swstim on July 09, 2013 19:52:58

Yes, thanks for the reminder, this had fallen off my radar. It's fixed for 2.3.0 #20 r1106 .

Status: Fixed

Member

Jeff0S commented Jul 8, 2014

From swstim on July 09, 2013 19:52:58

Yes, thanks for the reminder, this had fallen off my radar. It's fixed for 2.3.0 #20 r1106 .

Status: Fixed

@Jeff0S

This comment has been minimized.

Show comment
Hide comment
@Jeff0S

Jeff0S Jul 8, 2014

Member

From markus.h...@gmail.com on July 13, 2013 04:38:39

hi tim,

thanks a lot, works perfectly!! :) :)
sent you a small donation to show my thankfulness! ;)

best greetings from switzerland,
markus

Member

Jeff0S commented Jul 8, 2014

From markus.h...@gmail.com on July 13, 2013 04:38:39

hi tim,

thanks a lot, works perfectly!! :) :)
sent you a small donation to show my thankfulness! ;)

best greetings from switzerland,
markus

@Jeff0S

This comment has been minimized.

Show comment
Hide comment
@Jeff0S

Jeff0S Jul 8, 2014

Member

From swstim on July 13, 2013 06:32:21

Thanks, Markus!! Glad the fix works for you.

Member

Jeff0S commented Jul 8, 2014

From swstim on July 13, 2013 06:32:21

Thanks, Markus!! Glad the fix works for you.

@Jeff0S Jeff0S closed this Jul 8, 2014

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment